Jump to content






Photo - - - - -

eigrp routing issues

Posted by mtariqali , 20 February 2012 · 1020 views

Can any1 help me regarding missing routes in eigrp. currently i am running the eigrp between branch and HO. issue is that some time all branches route at HO will disappear from routing table but branches still getting the routes of HO. then i clear all eigrp neighbours at HO then again branches routes appear in routing table. i am unable to understand the problem. can any 1 help me in thsi:

HO Config: at Ho i have provided only one branch GRE tunnel network same i have around 200 branches:
router eigrp 500
redistribute static route-map REDISTRIBUTE-EIGRP
network 172.10.1.228 0.0.0.3
network 172.10.0.28 0.0.0.3
distribute-list DISTRIBUTE-LIST-EIGRP out
no auto-summary

ip access-list standard DISTRIBUTE-LIST-EIGRP
permit 10.10.10.11
permit 172.16.254.0 0.0.0.3
permit 10.10.2.0 0.0.0.255
permit 10.10.201.0 0.0.0.255
permit 10.10.203.0 0.0.0.255
permit 10.10.250.0 0.0.0.255
permit 10.12.1.0 0.0.0.255

route-map REDISTRIBUTE-EIGRP permit 10
match ip address DISTRIBUTE-LIST-EIGRP

G.703#sh ip route eigrp 500
G.703#


Branch end:
router eigrp 500
network 10.10.39.0 0.0.0.255
network 172.10.0.28 0.0.0.3
network 172.10.1.228 0.0.0.3
no auto-summary

GMK-39#sh ip route eigrp 500
172.16.0.0/30 is subnetted, 1 subnets
D EX    172.16.254.0 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
[170/22800128] via 172.10.0.29, 00:21:43, Tunnel2
10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
D EX    10.10.10.11/32 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
   [170/22800128] via 172.10.0.29, 00:21:43, Tunnel2
D EX    10.10.2.0/24 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
[170/22800128] via 172.10.0.29, 00:21:43, Tunnel2
D EX    10.12.1.0/24 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
[170/22800128] via 172.10.0.29, 00:21:43, Tunnel2
D EX    10.10.201.0/24 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
   [170/22800128] via 172.10.0.29, 00:21:43, Tunnel2
D EX    10.10.203.0/24 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
   [170/22800128] via 172.10.0.29, 00:21:43, Tunnel2
D EX    10.10.250.0/24 [170/22800128] via 172.10.1.229, 00:21:43, Tunnel0
   [170/22800128] via 172.10.0.29, 00:21:43, Tunnel2




any one with any suggestion
It seems like you are having some recursive routing issues here.. but why would you use a blog post to ask a question?.. probably a post in one of the forums could give you a better reply ratio..
hi

which ones are the IPs of the tunnels. These IPs must not be known through the tunnel.
i am talking about source and destination IPs in both sides
AT Branch
interface Tunnel0
description <<<LDN>>>
bandwidth 256
ip address 172.10.1.230 255.255.255.252
ip mtu 1352
ip ospf cost 100
keepalive 10 1
tunnel source 172.31.0.46
tunnel destination 172.31.0.250

AT COK:
interface Tunnel0
description <<<LDN>>>
bandwidth 256
ip address 172.10.1.229 255.255.255.252
ip mtu 1352
ip ospf cost 100
keepalive 10 1
tunnel source 172.31.0.250
tunnel destination 172.31.0.46

October 2014

S M T W T F S
   1 2 34
567891011
12131415161718
19202122232425
262728293031 

Recent Entries

Recent Comments

Tags

    Search My Blog

    Categories

    Organization

    Community

    Downloads

    Test Providers

    Site Info


    Go to top