Jump to content


5

K7 - My Adv. BGP solution..

K7 Advance BGP BGP

38 replies to this topic

#1 lasttouch

lasttouch

    Member

  • Members
  • PipPip
  • 30 posts
  • 715 thanks

Posted 18 June 2012 - 10:47 AM

Guys Advance BGP solution is Cisco Divers path, Its a new feature Cisco Launched run on IOS 15.2.. in this RR can advertise backup route to its Client.. What i think Cisco want us to learn these new thing.. may be thats y, they introduce this things in Lab 5(New Lab), I tested it on IOU, Its working, but i don't know cisco is using 15.2 IOS on Lab 5 or not.. i think it should be 15.2 on Lab 5.

See below my solution..


2.7 Advanced BGP

Configure BGP path selection as following requirements
· Redistribute OSPF into BGP on R1 and R2
· R1 should prefer the path pointing to BB1 AS 254,the bgp tie breaker for best path selection has to be “Internal Vs External” Criteria
· R3 should prefer the path through R1 to BB1 for reaching AS 254. This configuration should not affect any other routers in AS YY getting to  BGP AS 254
· You are not allowed to change BGP attributes Weight, AS-Path or Local Preference on R4 and R5 to accomplish this task
· You are allowed to change the ospf cost of only one interface.
· R4 should prefer R1 as exit point for reaching AS 254
· R4 should ping a prefix 197.68.1.254 network in learned from BGP AS254


SOLUTION:

On R1

router bgp 5
bgp bestpath as-path ignore
redistribute ospf 5 match internal external 1 external 2


On R2

router bgp 5
redistribute ospf 5 match internal external 1 external 2


On R3

router bgp 5
address-family ipv4
  bgp additional-paths install
  neighbor 5.5.1.1 activate
  neighbor 5.5.1.1 weight 500
  neighbor 5.5.4.4 activate
  neighbor 5.5.4.4 route-reflector-client
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 route-reflector-client
  neighbor 5.5.5.5 advertise diverse-path backup
exit-address-family


interface Serial1/1 **** Going Towards R2
ip ospf cost 1




Output

IOS

Rack05R4#show ver
Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(2.15)T, ENGINEERING WEEKLY BUILD, synced to V151_4_M3_5
Copyright © 1986-2012 by Cisco Systems, Inc.
Compiled Sun 29-Jan-12 02:33 by


Internal  vs  External

Rack05R1#sb | in 197|.254
*>  197.68.1.0    150.1.5.254   0 0 254 253 i
*>  197.68.4.0    150.1.5.254   0 0 254 253 i
*>  197.68.5.0    150.1.5.254   0 0 254 253 i
*>  197.68.21.0   150.1.5.254   0 0 254 253 i
*>  197.68.22.0   150.1.5.254   0 0 254 253 i

Rack05R1#sr 197.68.1.0
Routing entry for 197.68.1.0/24
  Known via "bgp 5", distance 20, metric 0
  Tag 254, type external
  Last update from 150.1.5.254 00:44:55 ago
  Routing Descriptor Blocks:
  * 150.1.5.254, from 150.1.5.254, 00:44:55 ago
  Route metric is 0, traffic share count is 1
  AS Hops 2
  Route tag 254
  MPLS label: none

Rack05R1(config)#router bgp 5
Rack05R1(config-router)#neighbor 150.1.5.254 shutdown

*Jun 16 16:07:20.081: %BGP-5-ADJCHANGE: neighbor 150.1.5.254 Down Admin. shutdown
*Jun 16 16:07:20.081: %BGP_SESSION-5-ADJCHANGE: neighbor 150.1.5.254 IPv4 Unicast topology base removed from session  Admin. Shutdown


(its only for verification after that do "no neighbor 150.1.5.254 shutdown")

Rack05R1#sb | in 197|.254
*>i 197.68.1.0    150.2.5.254   0 100   0 254 i
*>i 197.68.4.0    150.2.5.254   0 100   0 254 i
*>i 197.68.5.0    150.2.5.254   0 100   0 254 i
*>i 197.68.21.0   150.2.5.254   0 100   0 254 i
*>i 197.68.22.0   150.2.5.254   0 100   0 254 i

Rack05R1#sr 197.68.1.0
Routing entry for 197.68.1.0/24
  Known via "bgp 5", distance 200, metric 0
  Tag 254, type internal
  Last update from 150.2.5.254 00:00:11 ago
  Routing Descriptor Blocks:
  * 150.2.5.254, from 5.5.3.3, 00:00:11 ago
  Route metric is 0, traffic share count is 1
  AS Hops 1
  Route tag 254
  MPLS label: none

R3 Following R1 to get BB's routes

Rack05R3#sb | in 197|.254
*>i 197.68.1.0    150.1.5.254   0 100 500 254 253 i
*bi   150.2.5.254   0 100   0 254 i
*>i 197.68.4.0    150.1.5.254   0 100 500 254 253 i
*bi   150.2.5.254   0 100   0 254 i
*>i 197.68.5.0    150.1.5.254   0 100 500 254 253 i
*bi   150.2.5.254   0 100   0 254 i
*>i 197.68.21.0   150.1.5.254   0 100 500 254 253 i
*bi   150.2.5.254   0 100   0 254 i
*>i 197.68.22.0   150.1.5.254   0 100 500 254 253 i
*bi   150.2.5.254   0 100   0 254 i

R5 Following R2 to get BB's routes

Rack05R5#sb | in 197|.254
*>i 197.68.1.0    150.2.5.254   0 100   0 254 i
*>i 197.68.4.0    150.2.5.254   0 100   0 254 i
*>i 197.68.5.0    150.2.5.254   0 100   0 254 i
*>i 197.68.21.0   150.2.5.254   0 100   0 254 i
*>i 197.68.22.0   150.2.5.254   0 100   0 254 i

R4 Following R1 to get BB's routes and ping Successfully.

Rack05R4#sb | in 197|.254
*>i 197.68.1.0    150.1.5.254   0 100   0 254 253 i
*>i 197.68.4.0    150.1.5.254   0 100   0 254 253 i
*>i 197.68.5.0    150.1.5.254   0 100   0 254 253 i
*>i 197.68.21.0   150.1.5.254   0 100   0 254 253 i
*>i 197.68.22.0   150.1.5.254   0 100   0 254 253 i

Rack05R4#ping 197.68.1.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 197.68.1.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 10/10/12 ms




Now i have only this one issue..

Rack05R4#trace 197.68.1.254
Type escape sequence to abort.
Tracing the route to 197.68.1.254
VRF info: (vrf in name/id, vrf out name/id)
  1 5.5.34.3 3 msec 1 msec 1 msec
  2 5.5.23.2 11 msec 12 msec 12 msec
  3 150.2.5.254 10 msec 12 msec *



If i increase the ospf cost on R3 S1/1(R3>>R2) then packet goes to R5 and according to R5 197.68.1.254 route learned via 150.2.5.254 and the best path for it is R3.. so its send back to R3 again.. then loop occurs..

Kindly All experts, I need ur concerntration on this.. We are close to solution.

All Comments and suggestions are welcome..

Edited by crackerjoe69, 29 June 2012 - 07:52 AM.
color edit, red is for moderation use only


#2 zenek89

zenek89

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts
  • 13 thanks

Posted 18 June 2012 - 12:55 PM

DUplicate Post, i wrote this in another topic but for sure 12.4(15)T dont support that feature

#3 evolved

evolved

    Advanced Member

  • Members
  • PipPipPip
  • 651 posts
  • 1348 thanks

Posted 18 June 2012 - 01:04 PM

Is there anything similar to this feature in 12.4 that was used temporarily and then the decided to create it as a standard feature in 15.0 code?

#4 sursurya

sursurya

    Advanced Member

  • Members
  • PipPipPip
  • 97 posts
  • 67 thanks

Posted 18 June 2012 - 02:13 PM

can we try to find this by  IOS release doc

#5 lasttouch

lasttouch

    Member

  • Members
  • PipPip
  • 30 posts
  • 715 thanks

Posted 18 June 2012 - 02:34 PM

So Lab 5 is also using 12.4 IOS ?? sure abt it ??


Someone did "show version" in lab ?

Edited by lasttouch, 18 June 2012 - 02:34 PM.


#6 Guest_vertex_*

Guest_vertex_*
  • Guests
  • thanks

Posted 18 June 2012 - 03:07 PM

View Postlasttouch, on 18 June 2012 - 02:34 PM, said:

So Lab 5 is also using 12.4 IOS ?? sure abt it ??


Someone did "show version" in lab ?

same ios as all the other labs. it didnt run anything in the 15x range.

#7 evolved

evolved

    Advanced Member

  • Members
  • PipPipPip
  • 651 posts
  • 1348 thanks

Posted 18 June 2012 - 03:22 PM

They have to use 12.4 unless they provide updated version of the lab.

#8 apache2248

apache2248

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • 28 thanks

Posted 18 June 2012 - 03:31 PM

If i increase the ospf cost on R3 S1/1(R3>>R2) then packet goes to R5 and according to R5 197.68.1.254 route learned via 150.2.5.254 and the best path for it is R3.. so its send back to R3 again.. then loop occurs..

Kindly All experts, I need ur concerntration on this.. We are close to solution.


Hi evolved am also stuck at this point..but what you think if the requirement of no other peers should effected by the change is only applicable to R2(only ebgp peer routers).I cant see any logic in traffic engineering R5 as this will come under the transit path to R1 ..

Apache

#9 evolved

evolved

    Advanced Member

  • Members
  • PipPipPip
  • 651 posts
  • 1348 thanks

Posted 18 June 2012 - 04:04 PM

I'm not so concerned about Adv. BGP at the moment, I'd be more concerned about optimization. This question as of right now is like OER, you can get it wrong and do well on the other sections and pass. So I would suggest focusing on the optimization and services.

#10 Guest_solo356_*

Guest_solo356_*
  • Guests
  • thanks

Posted 18 June 2012 - 04:12 PM

I agree with evolved.

Regards

Thanked by 1 Member:
n1ghthawk

#11 ccielabT

ccielabT

    Advanced Member

  • Members
  • PipPipPip
  • 115 posts
  • 226 thanks

Posted 18 June 2012 - 04:18 PM

please Gentelmen, whenever you take lab exam always remember which version of IOS (full version note) is running .. Thanks for advance..

#12 UldisD

UldisD

    Cisco TE

  • Super Moderators
  • 1949 posts
  • 63506 thanks

Posted 18 June 2012 - 04:48 PM

show vers in lab
doesnt support any diversity and additinal path..
sure fo 100%

version on lab 12.4.(15)T

IT DOESN'T SUPPORT ANY OF THESE FEATURES...

#13 ccielabT

ccielabT

    Advanced Member

  • Members
  • PipPipPip
  • 115 posts
  • 226 thanks

Posted 18 June 2012 - 05:14 PM

Yeah man .. i also tried ,, not working

@lasttouch , where did you get ENGINEERING version of IOS Version 15.2(2.15)T,

I think those IOS will support all commands from start to end.

Edited by ccielabT, 18 June 2012 - 05:17 PM.


Thanked by 1 Member:
sorrasak

#14 ccieguy19787

ccieguy19787

    Advanced Member

  • Members
  • PipPipPip
  • 67 posts
  • 2 thanks

Posted 19 June 2012 - 03:39 AM

http://www.cisco.com/en/US/docs/ios/ios_xe/iproute_bgp/configuration/guide/irg_diverse_path_xe.html#wp1054287




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top