Jump to content


3

TS5-ppp multilink issue


28 replies to this topic

#15 rainrain

rainrain

    Member

  • Members
  • PipPip
  • 41 posts
  • 47 thanks

Posted 09 February 2013 - 08:51 AM

Hi Pravine,
  Thanks for this post. However, this much was working for me also and it is already solved in the forum. Could you check FRTS question of connecting R26 to R23 after correcting the FR routing issue keeping this PPP Multilink config? If we solve it separately we wouldn't know the dependent issues.
Also why the connection from R25 - R26 not working though it is not a exam requirement.

If we could use the second ACL below and use it in NAT..everything works fine.

Existing ACL on R26:
   access-list 100 permit ip host 100.26.26.26 any
Ideal ACL:
  access-list 100 permit ip 192.168.20.0 0.0.0.3 any

Thanks

#16 naunglay

naunglay

    Advanced Member

  • Members
  • PipPipPip
  • 111 posts
  • 180 thanks

Posted 09 February 2013 - 09:31 AM

don't remove any nat statement .
Just change interface to nat inside to outside.
Then do redistribution in OSPF ..
You will able to solve the problem.

If you remove the NAT statement, you will get trouble in next question.

#17 rainrain

rainrain

    Member

  • Members
  • PipPip
  • 41 posts
  • 47 thanks

Posted 09 February 2013 - 09:46 AM

I put the NAT statements back in as original.
Still FRTS question doesn't work for me after solving PPP as you said Naunglay.
I am using this IOS L3: /opt/iou/bin/i86bi_linux-adventerprisek9-15.2.15

Thanks

#18 naunglay

naunglay

    Advanced Member

  • Members
  • PipPipPip
  • 111 posts
  • 180 thanks

Posted 09 February 2013 - 10:10 AM

Hi,  If you remove NAT statement , you may not able to ping from R26 to R25 .

R26,  multi 1 interface must be  ip nat outside..


My working solution for FRTS .

map-class frame-relay frts
   frame-relay cir 1000
           frame-relay bc 8000
   service-policy output frts


R25# sh policy-map frts
  Policy Map frts
    Class class-default
  Average Rate Traffic Shaping
  cir 96000 (bps)
  shape adaptive 8000
  service-policy voice

R25#sh policy-map voice
  Policy Map voice
    Class voice
  priority 25 (%)
R25#sh class voice
Class Map match-all voice (id 1)
   Match ip  precedence 5

Edited by naunglay, 09 February 2013 - 10:13 AM.


Thanked by 1 Member:
rainrain

#19 rainrain

rainrain

    Member

  • Members
  • PipPip
  • 41 posts
  • 47 thanks

Posted 09 February 2013 - 10:28 AM

Pleas see my config and Verifications on R25, 26, 27


R26#show ppp multilink interface multilink 1

Multilink1
  Bundle name: cc1eR26
  Remote Endpoint Discriminator: [1] cc1eR26
  Local Endpoint Discriminator: [1] ccieR25
  Bundle up for 00:09:23, total bandwidth 3088, load 1/255
  Receive buffer limit 24000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 1 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x7D received sequence, 0x83 sent sequence
  Member links: 2 active, 0 inactive (max 255, min 1)
    Se1/1, since 00:09:23
    Se1/0, since 00:09:23
R26#
R26#show run int eth0/0
interface Ethernet0/0
ip address 192.168.20.1 255.255.255.0
ip nat outside
ip virtual-reassembly in

R26#show run | sec nat
ip nat outside
ip nat outside
ip nat inside source list 100 interface Loopback0 overload
ip nat inside source static 192.168.20.2 interface Loopback0
R26#
R26#show ip nat trans
R26#show ip nat translations
Pro Inside global   Inside local    Outside local   Outside global
--- 100.26.26.26    192.168.20.2    ---     ---
R26#
R26#show run | sec router ospf
router ospf 3
router-id 100.26.26.26
area 0 authentication message-digest
redistribute rip subnets
network 100.26.26.26 0.0.0.0 area 0
R26#show run | sec router rip
router rip
version 2
network 192.168.20.0
no auto-summary
R26#
R26#show ip route
R26#show ip route conn
R26#show ip route connected

  100.0.0.0/32 is subnetted, 4 subnets
C     100.25.25.25 is directly connected, Multilink1
C     100.26.26.26 is directly connected, Loopback0
  192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C     192.168.20.0/24 is directly connected, Ethernet0/0
L     192.168.20.1/32 is directly connected, Ethernet0/0
R26#
Ping from R26 to R25 and R23 fails..

Verification from R27:
R27#ping 100.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.23.23.23, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 25/29/35 ms
R27#
R27#
R27#
R27#ping 100.25.25.25
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.25.25.25, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/9 ms

Config on R25 for FRTS:
R25#show run | sec class-map
class-map match-all voice
match ip precedence 5
R25#show run | sec policy-map
policy-map voice
class voice
  priority percent 25
policy-map frts
class class-default
  shape average 96000
   service-policy voice
R25#show run | sec map-class
map-class frame-relay frts
frame-relay cir 1000
frame-relay bc 8000
service-policy output frts
R25#
R25#show run int s0/0 | incl class
frame-relay class frts

#20 naunglay

naunglay

    Advanced Member

  • Members
  • PipPipPip
  • 111 posts
  • 180 thanks

Posted 09 February 2013 - 10:49 AM

are you able to ping from R26 to R25 ?

#21 rainrain

rainrain

    Member

  • Members
  • PipPip
  • 41 posts
  • 47 thanks

Posted 09 February 2013 - 11:01 AM

No..Though I get connected route with /32 it doesn't ping..

#22 rainrain

rainrain

    Member

  • Members
  • PipPip
  • 41 posts
  • 47 thanks

Posted 09 February 2013 - 11:15 AM

Hi friends ..thanks for your inputs..

I checked with UldisD about this issue. He asked to use 12.4 TPG and after I changed the IOS everything worked fine :)

I kept the NAT config as it is as Naunglay said but I did not use redistribution on OSPF..everything worked fine without that..

So, guys for UldisD Web IOU TS5 v4.04 please use 12.4 TPG for layer3 devices.

Thanks

Thanked by 1 Member:
naunglay

#23 cisco69

cisco69

    Advanced Member

  • Members
  • PipPipPip
  • 96 posts
  • 57 thanks

Posted 09 February 2013 - 11:51 AM

Hi,
i confirm that with 12.4 TPG (for now only on r25 and r26) it works well.
Thanks to pravine, rainrain and legendary UldisD.
Regards

#24 naunglay

naunglay

    Advanced Member

  • Members
  • PipPipPip
  • 111 posts
  • 180 thanks

Posted 09 February 2013 - 11:57 PM

yes. confirmed..
Just only need to configure multilink and wait for 1 to 2 min.
It is working.

#25 cisco69

cisco69

    Advanced Member

  • Members
  • PipPipPip
  • 96 posts
  • 57 thanks

Posted 10 February 2013 - 01:07 PM

Hi guys,
in general in ppp questions, when we have authentication chap, (for example) is better to change:
1) username user password passwd in the local database of the router
2) ppp chap user and ppp chap pass

or it's the same thing?
Thanks and regards

#26 pravine

pravine

    Cisco TE

  • Technical Expert
  • PipPipPipPipPip
  • 1140 posts
  • 10118 thanks
  • LocationCCIE Land

Posted 11 February 2013 - 02:04 AM

@cisco69
I think either one should be ok.  I will change the 2nd option.

Now about both NAT ticket and FRTS ticket(It is MQC based in UldsD, but looks like in exam you might get legacy FRTS)

I did both NAT and Multilink
In NAT for NAT to work you need to have "ip nat outside" on multilink interface R26 but when you do FRTS, you are forced to remove "ip nat outside" from multilink interface and add to loopback interface.
When you do this FRTS-QOS works but NAT fails.  I couldn't fix this issue.

But one of my friend went for exam recently and confirming there was no NAT on R26, rater, RIP was redistributed to ospf(one way redistribution) only.
If anyone solved both NAT/QOS ticket best to get that information.

Or need to verify from exam takers if there was really NAT in the exam or at R26 RIP was redistributed to OSPF.

Thanked by 1 Member:
cisco69

#27 pravine

pravine

    Cisco TE

  • Technical Expert
  • PipPipPipPipPip
  • 1140 posts
  • 10118 thanks
  • LocationCCIE Land

Posted 11 February 2013 - 04:03 AM

Pls use 12.4TPG IOS code and try both together
Thanks UldsD for information

Thanked by 1 Member:
cisco69

#28 student009

student009

    Advanced Member

  • Members
  • PipPipPip
  • 78 posts
  • 25 thanks

Posted 11 February 2013 - 07:02 PM

hi Pravine
   Thank for post it help to resolve this issue.I just want want clear my doubt if in  Lab if this think happen ? what is command to make protocor that there is IOS problem not config ?  i mean any verfication method ?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top