Jump to content


0

GNS3 Problem ( please help )


6 replies to this topic

#1 lp5

lp5

    Junior Member

  • Members
  • PipPip
  • 3 posts
  • 3 thanks

Posted 29 November 2010 - 08:02 AM

Dears,

I am having a problem with GNS3 , Please this is really frustrating , I've been trying for a very long time and i don't know what else to do , please guys share your experience.

When i test the path to dynamips it always gives me : Failed to start Dynamips , and when i drag a router to the workspace it always says : connecting to a hypervisor on port 7200 and then : can't connect to the hypervisor on port 7200 : [Errno: 10061] No connection could be made because the target machine actively refused it.

I have tried the following :

1. Uninstall GNS3 and reinstall it.
2. Open port UDP 7200 and add GNS3 to exceptions in windows firewall .
3. Disable windows firewall & Kaspersky Anti Virus .
4. Changed the working directory to a new one made by me ( C:\gns directory ).
5. made sure that the executable path to dynamips is : ( C:\Program Files\GNS3\dynamips-wxp.exe )

I am using windows XP professional version 2002 service pack 3 , 2.8 GHz , 3.45 GHz of RAM .
please guys let me know what can i do to solve this problem , I am preparing for my TSHOOT exam and i really need GNS3 , i have used before for routing preparation and it worked just fine !

Waiting for your helpful comments and feedback

#2 Glavin

Glavin

    VERSION 1.0

  • Senior Super Moderators
  • 698 posts
  • 42513 thanks

Posted 29 November 2010 - 09:14 AM

OK , Do one thing go to Program Files\Gns3 and run dynamips-start.cmd,  see whether it starts successfully. If it does here's a simple solution  for your problem. Run GNS3 and click  EDIT\ IOS images and hypervisors.   Then click External hypervisor Tab, Leave everything default and click  save, now click IOS images tab , browse to the IOS image you want to run  and then uncheck Use the hypervisor manager and click save. Now try  running that IOS image in GNS3 workbench. It should look thisAttached File  untitled.JPG   59.32K   64 downloads

IF this works for you, apply same method for other IOS images as well. Only thing is you'll have to manually start dynamips by going to Program Files\Gns3 and running dynamips-start.cmd and keep that command prompt window minimized till you exit gns3.
Before posting under Share sections, Make sure you've read the updated rules posted here http://certcollection.org/forum/forum-175/announcement-8-share-section-rules-read-before-posting/

Help us keep this forum clean by reporting spam / scam / non IT related posts and threads.

Follow us on http://twitter.com/certcollection

#3 lp5

lp5

    Junior Member

  • Members
  • PipPip
  • 3 posts
  • 3 thanks

Posted 29 November 2010 - 10:39 AM

View PostGlavin, on 29 November 2010 - 09:14 AM, said:

OK , Do one thing go to Program Files\Gns3 and run dynamips-start.cmd,  see whether it starts successfully. If it does here's a simple solution  for your problem. Run GNS3 and click  EDIT\ IOS images and hypervisors.   Then click External hypervisor Tab, Leave everything default and click  save, now click IOS images tab , browse to the IOS image you want to run  and then uncheck Use the hypervisor manager and click save. Now try  running that IOS image in GNS3 workbench. It should look thisAttachment untitled.JPG

IF this works for you, apply same method for other IOS images as well. Only thing is you'll have to manually start dynamips by going to Program Files\Gns3 and running dynamips-start.cmd and keep that command prompt window minimized till you exit gns3.

Thanks for the reply Glavin
unfortunately that didn't work , when i double click the ( dynamips-start.cmd ) it gives a cmd window that say : press any key to continue , when i press any key the window disappears .
also when i unchek the ( use local hypervisor ) and press save , it says :( no hypervisor selected , use the local hypervisor )
please help

#4 Glavin

Glavin

    VERSION 1.0

  • Senior Super Moderators
  • 698 posts
  • 42513 thanks

Posted 29 November 2010 - 12:11 PM

OK, try adding dynamips-wxp.exe to Exceptions under Windows Firewall.
Before posting under Share sections, Make sure you've read the updated rules posted here http://certcollection.org/forum/forum-175/announcement-8-share-section-rules-read-before-posting/

Help us keep this forum clean by reporting spam / scam / non IT related posts and threads.

Follow us on http://twitter.com/certcollection

#5 kage

kage

    Member

  • Members
  • PipPip
  • 42 posts
  • 22 thanks

Posted 30 November 2010 - 09:22 PM

the order of operations should be:
1. delete any entries from firewall that are related to gns3
2. disable firewall /antivirus
3. uninstall gns
4. reboot
5. make sure that firewall / antivirus are disabled
6. reinstall gns3
7. start gns3 and test the functionality
8. add ios image (uncompress)
9. create topology
and most important, install another antivirus+firewall: search for symantec endpoint protection (antivirus+firewall)

#6 leochb

leochb

    Member

  • Members
  • PipPip
  • 25 posts
  • 8 thanks

Posted 02 December 2010 - 12:08 PM

HI guys, i need help to use gns3 0.72all_in_one(it says it is including dynamips,dynagen & qemu) for simulating ASA.I have a system having core 2 duo processor 2GHz,4GB RAM & win vista home-pre64 bit.anti virus is Mcafee internet security.im not able to figure how to simulate ASA. no options are there to save Ios for ASA.need to know whole process.plz help.what is needed to be done in dynamips console...plz help

Edited by leochb, 02 December 2010 - 12:13 PM.


#7 kirincastle

kirincastle

    Junior Member

  • Members
  • PipPip
  • 5 posts
  • 1 thanks

Posted 02 January 2011 - 07:00 AM

View Postleochb, on 02 December 2010 - 12:08 PM, said:

HI guys, i need help to use gns3 0.72all_in_one(it says it is including dynamips,dynagen & qemu) for simulating ASA.I have a system having core 2 duo processor 2GHz,4GB RAM & win vista home-pre64 bit.anti virus is Mcafee internet security.im not able to figure how to simulate ASA. no options are there to save Ios for ASA.need to know whole process.plz help.what is needed to be done in dynamips console...plz help

hi just check this link out,

http://blog.gns3.net/2009/12/how-to-emulate-cisco-asa/

it maybe better if u have linux installed on ur pc or notebook.
I am using Ubuntu, then follow the instruction, it works.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top