Jump to content






Photo - - - - -

Outputs hints and analysis

Posted by MSSK , 02 September 2012 · 1,435 views

Hi all

I was going the below link
http://blog.ine.com/2009/10/31/ccie-rs-troubleshooting-sample-trouble-tickets-part-1/
The ticket is already solved :) but i Just wanted to share some hints and ideas how to analyze the outputs

Let us go through some of the outputs
Transylvania#show ip protocols
Routing Protocol is "eigrp 100" à router eigrp 100
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0 --> No modifications to the default values
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect -->  no auto-summary
Maximum path: 4 --> This is the default value
Routing for Networks:
53.234.10.23/32 --> network 53.234.10.23 0.0.0.0
Routing Information Sources:
Gateway Distance   Last Update
Distance: internal 90 external 170
Routing Protocol is "bgp 65001" --> router bgp 65001
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled --> no synchronization
Automatic route summarization is disabled --> no auto-summary
Unicast Aggregate Generation:
10.10.0.0/16    summary-only --> aggregate-address 10.10.0.0 255.255.0.0 summary-only
Neighbor(s):

Address   FiltIn FiltOut DistIn DistOut Weight RouteMap
53.234.10.44    --> neighbor 53.234.10.44 remote-as ?     
Maximum path: 1
Routing Information Sources:
Gateway Distance   Last Update
Distance: external 20 internal 200 local 200
From the output above we can conclude that the router has a BGP peer with an IP address of 53.234.10.44 but we cannot tell if that neighbor is IBGP or EBGP from the show ip protocols  , we can check the show ip protocols on the other router and check the local AS then we can build the command to configure on this router
HalloweenTown#show ip protocols
Routing Protocol is "eigrp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not se
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0 --> No modifications to the default values
EIGRP maximum hopcount 100
EIGRP maximum metric variance
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect --> no auto-summary
Maximum path: 4
Routing for Networks:
53.234.10.44/32 --> network 53.234.10.44 0.0.0.0
Routing Information Sources:
Gateway Distance   Last Update
Distance: internal 90 external 170

Routing Protocol is "bgp 65001" --> router bgp 65001
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address   FiltIn FiltOut DistIn DistOut Weight RouteMap
23.10.24.190  --> neighbor 23.10.24.190 remote-as ?   
53.234.10.23  --> neighbor 53.234.10.23 remote-as ?  {65001}   (now checking the output above we can see that the remote-as will be the same 65001 , i.e. IBGP neighbor)     
Maximum path: 1
Routing Information Sources:
Gateway Distance   Last Update
Distance: external 20 internal 200 local 200

Salem#show ip protocol
Routing Protocol is "ospf 1" --> router ospf 1 (process ID 1)
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 66.150.201.12 --> router-id 66.150.201.12
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
Routing on Interfaces Configured Explicitly (Area 0): --> Backbone area
FastEthernet0/0 à The updates will use this interface to propagate
Reference bandwidth unit is 100 mbps
Routing Information Sources:  
Gateway Distance   Last Update
102.34.102.12     110   00:30:55 --> That means 102.34.102.12 is the DR of this shared segment
Distance: (default is 110)

Routing Protocol is "bgp 65000" --> router bgp 65000
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled --> no synchronization
Automatic route summarization is disabled --> no auto-summary
Neighbor(s):
Address   FiltIn FiltOut DistIn DistOut Weight RouteMap
23.10.24.200   --> neighbor 23.10.24.200 remote-as ? {65001} after checking the output above     
Maximum path: 1
Routing Information Sources:
Gateway Distance   Last Update
Distance: external 20 internal 200 local 20

CrystalLake#show ip protocol
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 102.34.102.1 --> router-id 102.34.102.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
Routing on Interfaces Configured Explicitly (Area 0):
FastEthernet0/1 --> interface from which the updates are propagated
FastEthernet0/0 --> interface from which the updates are propagated
Reference bandwidth unit is 100 mbps --> Default value
Routing Information Sources:
Gateway Distance   Last Updat
Distance: (default is 110)


Routing Protocol is "bgp 65000"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address   FiltIn FiltOut DistIn DistOut Weight RouteMap
66.150.201.12  --> neighbor 66.150.201.12 remote-as ? {65000} from the previous output   
Address   FiltIn FiltOut DistIn DistOut Weight RouteMap
102.34.102.12  --> neighbor 102.34.102.12 remote-as ? {65000} from the previous output     
Maximum path: 1
Routing Information Sources:
Gateway Distance   Last Update
Distance: external 20 internal 200 local 200

Amityville#show ip protocol
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not se
Router ID 102.34.102.12 --> router-id 102.34.102.12
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
Routing on Interfaces Configured Explicitly (Area 0):
FastEthernet0/0 --> The interface of which the updates is propagated
Reference bandwidth unit is 100 mbp
Routing Information Sources:
Gateway Distance   Last Update
102.34.102.1 110   00:33:23 -->  That means 102.34.102.12 is the DR of this shared segment
Distance: (default is 110)


Routing Protocol is "bgp 65000
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled --> no synchronization
Automatic route summarization is disabled --> no auto-summary
Neighbor(s):
Address   FiltIn FiltOut DistIn DistOut Weight RouteMap
102.34.102.1  --> neighbor 102.34.102.1 remote-as ? {65000} from the previous output   
Maximum path: 1
Routing Information Sources:
Gateway Distance   Last Update
Distance: external 20 internal 200 local 200

Transylvania#show ip int brief
Interface   IP-Address   OK? Method Status     Protocol
FastEthernet0/0     53.234.10.23    YES manual up     up   
FastEthernet0/1     unassigned   YES unset  administratively down down    
Loopback1   10.10.10.1   YES manual up     up   
Loopback2   10.10.11.1   YES manual up     up   
Loopback3   10.10.12.1   YES manual up     up  

As well, we can conclude that there are 3 loopback interfaces configured, we do not know the subnet mask but we can assume its 24 as the 3rd octct is different and we have summarization in place

Based on the outputs above we can configure as below (roughly)

Amity#sh run int f0/0
interface FastEthernet0/0
ip address 102.34.102.12 255.255.255.0
ip ospf 1 area 0
speed 100
full-duplex

Amity#sh run | sec router ospf
router ospf 1
router-id 102.34.102.12
log-adjacency-changes

Amity#sh run | sec router bgp
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 102.34.102.1 remote-as 65000
no auto-summary

Crystal#sh run int f0/
interface FastEthernet0/0
ip address 102.34.102.1 255.255.255.0
ip ospf 1 area 0
speed 100
full-duplex


Crystal#sh run int f0/1
interface FastEthernet0/1
ip address 66.150.201.21 255.255.255.0
ip ospf 1 area 0
speed 100
full-duplex

Crystal#sh run | sec router ospf
router ospf 1
router-id 102.34.102.1
log-adjacency-changes

Crystal#sh run | sec router bgp
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 66.150.201.12 remote-as 65000
neighbor 102.34.102.12 remote-as 65000
no auto-summary

Salem#sh run int f0/
interface FastEthernet0/0
ip address 66.150.201.12 255.255.255.0
ip ospf 1 area 0
speed 100
full-duplex

Salem#sh run int f0/
interface FastEthernet0/1
ip address 23.10.24.190 255.255.255.0
speed 100
full-duplex

Salem#sh run | sec router ospf
router ospf 1
router-id 66.150.201.12
log-adjacency-changes

Salem#sh run | sec router bgp
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 23.10.24.200 remote-as 65001
neighbor 66.150.201.21 remote-as 65000
no auto-summary

Halloween#sh run int f0/0
interface FastEthernet0/0
ip address 23.10.24.200 255.255.255.0
speed 100
full-duplex

Halloween#sh run int f0/
interface FastEthernet0/1
ip address 53.234.10.44 255.255.255.0
speed 100
full-duplex

Halloween#sh run | sec router bgp
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 23.10.24.190 remote-as 65000
neighbor 53.234.10.23 remote-as 65001
no auto-summary

Halloween#sh run | sec router eigrp
router eigrp 100
network 53.234.10.44 0.0.0.0
no auto-summary

Transy#sh run int f0/0
interface FastEthernet0/0
ip address 53.234.10.23 255.255.255.0
speed 100
full-duplex

Transy#sh run int loo1
interface Loopback1
ip address 10.10.10.1 255.255.255.0

Transy#sh run int loo2
interface Loopback2
ip address 10.10.11.1 255.255.255.0

Transy#sh run int loo3
interface Loopback3
ip address 10.10.12.1 255.255.255.0

Transy#sh run | sec router eigrp
router eigrp 100
network 53.234.10.23 0.0.0.0
no auto-summary

Transy#sh run | sec router bg
router bgp 65001
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
aggregate-address 10.10.0.0 255.255.0.0 summary-only
neighbor 53.234.10.44 remote-as 65001
no auto-summary


The missing configuration line was
Salem(config)#router bgp 65000
Salem(config-router)#neighbor 66.150.201.21 remote-as 65000


In order to establish BGP peering with Crystal router

Now , let us check what is going on on Transy router
Transy#sh ip bgp

we can see that there are no routes are installed in the routing table , even though the network statement is there and the loopbacks are configured and up , so what is the issue ?
The subnet mask in the network statement does not match any interface , so we have to change the subnet mask in the network statement under the router bgp configuration mode

Transy#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Transy(config)#router bgp 65001
Transy(config-router)#no network 10.0.0.0 mask 255.0.0.0
Transy(config-router)#network 10.10.10.0 mask 255.255.255.0
Transy(config-router)#end

Transy#sh ip bgp
BGP table version is 4, local router ID is 53.234.10.23
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*> 10.10.0.0/16 0.0.0.0     32768 i
s> 10.10.10.0/24    0.0.0.0   0 32768 i

Now , we can see the summary (as now we have a match)
Let us check if the route is advertised to the iBGP peer

Transy#sh ip bgp neighbors 53.234.10.44 advertised-routes
BGP table version is 4, local router ID is 53.234.10.23
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*> 10.10.0.0/16 0.0.0.0     32768 i

Total number of prefixes 1

Halloween#sh ip bgp
BGP table version is 2, local router ID is 53.234.10.44
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*>i10.10.0.0/16 53.234.10.23 0    100   0 i

Now from the Halloween router to its eBGP peer (Salem)

Halloween#sh ip bgp neighbors 23.10.24.190 advertised-routes
BGP table version is 2, local router ID is 53.234.10.44
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*>i10.10.0.0/16 53.234.10.23 0    100   0 i

Total number of prefixes 1

From Salem router

Salem#sh ip bgp neighbors 66.150.201.21 advertised-routes
BGP table version is 2, local router ID is 23.10.24.190
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*> 10.10.0.0/16 23.10.24.200    0 65001 i

Total number of prefixes 1

Moving to Crystal

Crystal#sh ip bgp
BGP table version is 1, local router ID is 102.34.102.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
* i10.10.0.0/16 23.10.24.200 0    100   0 65001 i

The route is not installed , can we check the next hop ?

Crystal#ping 23.10.24.200

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.10.24.200, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

No we cannot , so we have to configure the next-hop-self parameter on the Salem router towards Crystal

Salem#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Salem(config)#router bgp 65000
Salem(config-router)#neighbor 66.150.201.21 next-hop-self

Crystal#sh ip bgp     
BGP table version is 2, local router ID is 102.34.102.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*>i10.10.0.0/16 66.150.201.12     0    100   0 65001 i

Moving on

Crystal#sh ip bgp neighbors 102.34.102.12 advertised-routes

Total number of prefixes 0

No routes are advertised why ? because the split-horizon rule will prevent the route from being advertised to the iBGP neighbor , so we have to configure route-reflector

Crystal#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Crystal(config)#router bgp 65000
Crystal(config-router)#neighbor 102.34.102.12 route-reflector-client

*Mar  1 21:14:43.258: %BGP-5-ADJCHANGE: neighbor 102.34.102.12 Down RR client config change
*Mar  1 21:14:44.090: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 21:14:45.278: %BGP-5-ADJCHANGE: neighbor 102.34.102.12 Up

Crystal#sh ip bgp neighbors 102.34.102.12 advertised-routes
BGP table version is 2, local router ID is 102.34.102.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*>i10.10.0.0/16 66.150.201.12     0    100   0 65001 i

Total number of prefixes 1

Amity#sh ip bgp
BGP table version is 2, local router ID is 102.34.102.12
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
*>i10.10.0.0/16 66.150.201.12     0    100   0 65001 i

BR,
MSSK




November 2019

S M T W T F S
     12
3456789
10111213141516
1718 19 20212223
24252627282930

Recent Entries

Recent Comments

Tags

    Search My Blog

    Categories

    Organization

    Community

    Downloads

    Test Providers

    Site Info


    Go to top