Jump to content






Photo - - - - -

MSP Example #1

Posted by MSSK , 13 June 2013 · 1,792 views

MSP Example #1 Issue

In the above topology we are going to experience several features and implementations
  • ISIS Level-2 inside the core
  • BGP as PE-CE routing protocol
  • RIPv2 as PE-CE routing protocol (CsC)
  • MPLS Traffic Engineering inside the core
  IOS XR will be part of the topology and this is the main goal of this article as several configuration options will be implemented on it

Configuration


R1

interface Loopback0
ip address 11.11.11.11 255.255.255.255

interface FastEthernet0/0
no ip address
duplex full

interface FastEthernet0/0.111
encapsulation dot1Q 111
ip address 192.1.111.11 255.255.255.0

interface FastEthernet1/0
vrf forwarding ABC
ip address 172.1.17.1 255.255.255.0
duplex full

vrf definition ABC
rd 200:1
route-target export 200:1
route-target import 200:1
!
address-family ipv4
exit-address-family

router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 200
neighbor 6.6.6.6 update-source Loopback0
neighbor 22.22.22.22 remote-as 200
neighbor 22.22.22.22 update-source Loopback0
neighbor 192.1.111.1 remote-as 100

address-family ipv4
  no synchronization
  network 11.11.11.11 mask 255.255.255.255
  neighbor 192.1.111.1 activate
  neighbor 192.1.111.1 send-label
  no auto-summary
exit-address-family

address-family vpnv4
  neighbor 6.6.6.6 activate
  neighbor 6.6.6.6 send-community both
  neighbor 6.6.6.6 route-reflector-client
  neighbor 22.22.22.22 activate
  neighbor 22.22.22.22 send-community both
  neighbor 22.22.22.22 route-reflector-client
exit-address-family
!
address-family ipv4 vrf ABC
  no synchronization
  redistribute rip
exit-address-family

router rip

address-family ipv4 vrf ABC
  redistribute bgp 200 metric 1
  network 172.1.0.0
  no auto-summary
  version 2
exit-address-family

R2

interface Loopback0
ip address 22.22.22.22 255.255.255.255

interface FastEthernet0/0
no ip address
duplex full

interface FastEthernet0/0.222
encapsulation dot1Q 222
ip address 192.1.222.22 255.255.255.0

interface FastEthernet1/0
vrf forwarding ABC
ip address 172.1.28.2 255.255.255.0
duplex full

vrf definition ABC
rd 200:1
route-target export 200:1
route-target import 200:1

address-family ipv4
exit-address-family

router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 11.11.11.11 remote-as 200
neighbor 11.11.11.11 update-source Loopback0
neighbor 192.1.222.2 remote-as 100

address-family ipv4
  no synchronization
  network 22.22.22.22 mask 255.255.255.255
  neighbor 192.1.222.2 activate
  neighbor 192.1.222.2 send-label
  no auto-summary
exit-address-family

address-family vpnv4
  neighbor 11.11.11.11 activate
  neighbor 11.11.11.11 send-community both
exit-address-family

address-family ipv4 vrf ABC
  no synchronization
  redistribute rip
exit-address-family

router rip

address-family ipv4 vrf ABC
  redistribute bgp 200 metric 1
  network 172.1.0.0
  no auto-summary
  version 2
exit-address-family

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255

interface FastEthernet0/0
no ip address
duplex full

interface FastEthernet0/0.13
encapsulation dot1Q 13
ip address 192.1.13.3 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.23
encapsulation dot1Q 23
ip address 192.1.23.3 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 192.1.34.3 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.35
encapsulation dot1Q 35
ip address 192.1.35.3 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

mpls traffic-eng tunnels
mpls label protocol ldp
mpls ldp router-id Loopback0

router isis 1
net 49.0001.0000.0000.0003.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 100
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
neighbor 5.5.5.5 remote-as 100
neighbor 5.5.5.5 update-source Loopback0

address-family ipv4
  no synchronization
  no auto-summary
exit-address-family

address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community both
  neighbor 1.1.1.1 route-reflector-client
  neighbor 1.1.1.1 next-hop-self
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
  neighbor 2.2.2.2 route-reflector-client
  neighbor 2.2.2.2 next-hop-self
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community both
  neighbor 4.4.4.4 route-reflector-client
  neighbor 4.4.4.4 next-hop-self
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community both
  neighbor 5.5.5.5 route-reflector-client
  neighbor 5.5.5.5 next-hop-self
exit-address-family

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255

interface FastEthernet0/0
no ip address
duplex full

interface FastEthernet0/0.14
encapsulation dot1Q 14
ip address 192.1.14.4 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.34
encapsulation dot1Q 34
ip address 192.1.34.4 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 192.1.45.4 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.46
vrf forwarding MSSK
encapsulation dot1Q 46
ip address 192.1.46.4 255.255.255.0
mpls bgp forwarding

mpls traffic-eng tunnels
mpls label protocol ldp
mpls ldp router-id Loopback0

vrf definition MSSK
rd 100:1
route-target export 100:1
route-target import 100:1

address-family ipv4
exit-address-family

router isis 1
net 49.0001.0000.0000.0004.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0

address-family ipv4
  no synchronization
  no auto-summary
exit-address-family

address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
exit-address-family

address-family ipv4 vrf MSSK
  no synchronization
  neighbor 192.1.46.6 remote-as 200
  neighbor 192.1.46.6 activate
  neighbor 192.1.46.6 as-override
  neighbor 192.1.46.6 send-label
exit-address-family

R5

interface Loopback0
ip address 5.5.5.5 255.255.255.255

interface FastEthernet0/0
no ip address
duplex full

interface FastEthernet0/0.25
encapsulation dot1Q 25
ip address 192.1.25.5 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.35
encapsulation dot1Q 35
ip address 192.1.35.5 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

interface FastEthernet0/0.45
encapsulation dot1Q 45
ip address 192.1.45.5 255.255.255.0
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth

mpls traffic-eng tunnels
mpls label protocol ldp
mpls ldp router-id Loopback0

vrf definition MSSK
rd 100:1
route-target export 100:1
route-target import 100:1

address-family ipv4
exit-address-family

router isis 1
net 49.0001.0000.0000.0005.00
is-type level-2-only
metric-style wide
passive-interface Loopback0
mpls ldp autoconfig
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2

router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback0

address-family ipv4
  no synchronization
  no auto-summary
exit-address-family

address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
exit-address-family



R6

interface Loopback0
ip address 6.6.6.6 255.255.255.255

interface FastEthernet0/0
ip address 192.1.46.6 255.255.255.0
duplex full
mpls bgp forwarding

interface FastEthernet1/0
vrf forwarding ABC
ip address 172.1.106.6 255.255.255.0
duplex full

vrf definition ABC
rd 200:1
route-target export 200:1
route-target import 200:1

address-family ipv4
exit-address-family

router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 11.11.11.11 remote-as 200
neighbor 11.11.11.11 update-source Loopback0
neighbor 192.1.46.4 remote-as 100

address-family ipv4
  no synchronization
  network 6.6.6.6 mask 255.255.255.255
  neighbor 192.1.46.4 activate
  neighbor 192.1.46.4 send-label
  no auto-summary
exit-address-family

address-family vpnv4
  neighbor 11.11.11.11 activate
  neighbor 11.11.11.11 send-community both
exit-address-family

address-family ipv4 vrf ABC
  no synchronization
  redistribute rip
exit-address-family

router rip

address-family ipv4 vrf ABC
  redistribute bgp 200 metric 1
  network 172.1.0.0
  no auto-summary
  version 2
exit-address-family

R7

interface Loopback0
ip address 172.7.7.7 255.255.255.255

interface FastEthernet0/0
ip address 172.1.17.7 255.255.255.0
speed auto
full-duplex

router rip
version 2
network 172.1.0.0
network 172.7.0.0
no auto-summary


R8

interface Loopback0
ip address 172.8.8.8 255.255.255.255

interface FastEthernet0/0
ip address 172.1.28.8 255.255.255.0
speed auto
full-duplex

router rip
version 2
network 172.1.0.0
network 172.8.0.0
no auto-summary

R10

interface Loopback0
ip address 172.10.10.10 255.255.255.255

interface FastEthernet0/0
ip address 172.1.106.10 255.255.255.0
speed auto
full-duplex

router rip
version 2
network 172.1.0.0
network 172.10.0.0
no auto-summary

SW1

vlan 13-14,17,23,25,28,34-35,45-46,59,111,222,610

interface Port-channel1
port-type nni
switchport mode trunk

interface FastEthernet0/1
port-type nni
switchport mode trunk
duplex full

interface FastEthernet0/2
port-type nni
switchport mode trunk
duplex full

interface FastEthernet0/3
port-type nni
switchport mode trunk
duplex full

interface FastEthernet0/4
port-type nni
switchport mode trunk
duplex full

interface FastEthernet0/5
port-type nni
switchport mode trunk
duplex full

interface FastEthernet0/6
switchport access vlan 46
duplex full

interface FastEthernet0/7
switchport access vlan 17
duplex full

interface FastEthernet0/8
switchport access vlan 28
duplex full

interface FastEthernet0/9
switchport access vlan 59
shutdown
duplex full

interface FastEthernet0/10
switchport access vlan 610
duplex full

interface FastEthernet0/20
port-type nni
switchport mode trunk
duplex full
channel-group 1 mode on
!
interface FastEthernet0/21
port-type nni
switchport mode trunk
duplex full
channel-group 1 mode on

interface GigabitEthernet0/1
port-type nni
switchport mode trunk
speed nonegotiate

interface GigabitEthernet0/2
port-type nni
switchport mode trunk
speed nonegotiate

SW2

vlan 13-14,17,23,25,28,34-35,45-46,59,111,222,610

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/1
switchport access vlan 17
switchport mode access
duplex full

interface FastEthernet0/2
switchport access vlan 28
switchport mode access
duplex full

interface FastEthernet0/6
switchport access vlan 610
switchport mode access
duplex full

interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
channel-group 1 mode on

interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
channel-group 1 mode on

XR1

interface Loopback0
ipv4 address 1.1.1.1 255.255.255.255

interface GigabitEthernet0/1/0/0.13
ipv4 address 192.1.13.1 255.255.255.0
dot1q vlan 13

interface GigabitEthernet0/1/0/0.14
ipv4 address 192.1.14.1 255.255.255.0
dot1q vlan 14

interface GigabitEthernet0/1/0/0.111
vrf MSSK
ipv4 address 192.1.111.1 255.255.255.0
dot1q vlan 111

interface POS0/6/0/0
ipv4 address 192.1.12.1 255.255.255.0
encapsulation ppp

vrf MSSK
address-family ipv4 unicast
  import route-target
   100:1
  export route-target
   100:1

route-policy RPL
  pass
end-policy

router isis 1
is-type level-2-only
net 49.0001.0000.0000.0001.00
address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only

interface Loopback0
  address-family ipv4 unicast

interface GigabitEthernet0/1/0/0.13
  address-family ipv4 unicast

interface GigabitEthernet0/1/0/0.14
  address-family ipv4 unicast

interface POS0/6/0/0
  address-family ipv4 unicast

mpls ldp
router-id 1.1.1.1
interface GigabitEthernet0/1/0/0.13

interface GigabitEthernet0/1/0/0.14

interface POS0/6/0/0

router bgp 100
address-family vpnv4 unicast

neighbor 3.3.3.3
  remote-as 100
  update-source Loopback0
  address-family vpnv4 unicast

vrf MSSK
  rd 100:1
  address-family ipv4 unicast
   allocate-label all

  neighbor 192.1.111.11
   remote-as 200
   address-family ipv4 labeled-unicast
    route-policy RPL in
    route-policy RPL out
    as-override

router static
address-family ipv4 unicast
  2.2.2.2/32 tunnel-te0

vrf MSSK
  address-family ipv4 unicast
   192.1.111.11/32 GigabitEthernet0/1/0/0.111


rsvp
interface POS0/6/0/0

interface GigabitEthernet0/1/0/0.13

interface GigabitEthernet0/1/0/0.14

mpls traffic-eng
interface POS0/6/0/0

interface GigabitEthernet0/1/0/0.13

interface GigabitEthernet0/1/0/0.14

explicit-path name XR2
index 1 next-address strict ipv4 unicast 192.1.13.3
index 2 next-address strict ipv4 unicast 192.1.34.4
index 3 next-address strict ipv4 unicast 192.1.45.5
index 4 next-address strict ipv4 unicast 192.1.25.2

interface tunnel-te0
ipv4 unnumbered Loopback0
destination 2.2.2.2
path-option 1 explicit name XR2

XR2

interface Loopback0
ipv4 address 2.2.2.2 255.255.255.255

interface GigabitEthernet0/4/0/0.23
ipv4 address 192.1.23.2 255.255.255.0
dot1q vlan 23

interface GigabitEthernet0/4/0/0.25
ipv4 address 192.1.25.2 255.255.255.0
dot1q vlan 25

interface GigabitEthernet0/4/0/0.222
vrf MSSK
ipv4 address 192.1.222.2 255.255.255.0
dot1q vlan 222

interface POS0/7/0/0
ipv4 address 192.1.12.2 255.255.255.0
encapsulation ppp

router isis 1
is-type level-2-only
net 49.0001.0000.0000.0002.00
address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only

interface Loopback0
  address-family ipv4 unicast

interface GigabitEthernet0/4/0/0.23
  address-family ipv4 unicast

interface GigabitEthernet0/4/0/0.25
  address-family ipv4 unicast

interface POS0/7/0/0
  address-family ipv4 unicast

vrf MSSK
address-family ipv4 unicast
  import route-target
   100:1
  export route-target
   100:1

route-policy RPL
  pass
end-policy

mpls ldp
router-id 2.2.2.2
interface GigabitEthernet0/4/0/0.23

interface GigabitEthernet0/4/0/0.25

interface POS0/7/0/0


router bgp 100
address-family vpnv4 unicast

neighbor 3.3.3.3
  remote-as 100
  update-source Loopback0
  address-family vpnv4 unicast

vrf MSSK
  rd 100:1
  address-family ipv4 unicast
   allocate-label all

  neighbor 192.1.222.22
   remote-as 200
   address-family ipv4 labeled-unicast
    route-policy RPL in
    route-policy RPL out
    as-override

router static
address-family ipv4 unicast
  1.1.1.1/32 tunnel-te0

vrf MSSK
  address-family ipv4 unicast
   192.1.222.22/32 GigabitEthernet0/4/0/0.222

rsvp
interface POS0/7/0/0

interface GigabitEthernet0/4/0/0.23

interface GigabitEthernet0/4/0/0.25

mpls traffic-eng
interface POS0/7/0/0

interface GigabitEthernet0/4/0/0.23

interface GigabitEthernet0/4/0/0.25

explicit-path name XR1
index 1 next-address strict ipv4 unicast 192.1.23.3
index 2 next-address strict ipv4 unicast 192.1.34.4
index 3 next-address strict ipv4 unicast 192.1.14.1

interface tunnel-te0
ipv4 unnumbered Loopback0
destination 1.1.1.1
path-option 1 explicit name XR1

Verification

R1#sh ip bgp
BGP table version is 26, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network       Next Hop     Metric LocPrf Weight Path
*> 6.6.6.6/32    192.1.111.1     0 100 100 i
*> 11.11.11.11/32   0.0.0.0   0 32768 i
*> 22.22.22.22/32   192.1.111.1     0 100 100 i

R1#ping 6.6.6.6 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Packet sent with a source address of 11.11.11.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

R1#ping 22.22.22.22 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
Packet sent with a source address of 11.11.11.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

R1#traceroute 6.6.6.6 source lo0 numeric

Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 192.1.111.1 [MPLS: Label 16010 Exp 0] 4 msec 0 msec 4 msec
  2 192.1.46.4 [MPLS: Label 29 Exp 0] 4 msec 0 msec 0 msec
  3 192.1.46.6 0 msec *  0 msec

R1#traceroute 22.22.22.22 source lo0 numeric

Type escape sequence to abort.
Tracing the route to 22.22.22.22

  1 192.1.111.1 [MPLS: Label 16011 Exp 0] 4 msec 0 msec 4 msec
  2 192.1.13.3 [MPLS: Labels 25/16008 Exp 0] 4 msec 0 msec 0 msec
  3 192.1.34.4 [MPLS: Labels 20/16008 Exp 0] 4 msec 0 msec 4 msec
  4 192.1.45.5 [MPLS: Labels 17/16008 Exp 0] 0 msec 0 msec 4 msec
  5 192.1.25.2 [MPLS: Label 16008 Exp 0] 4 msec 4 msec 0 msec
  6 192.1.222.22 4 msec *  0 msec

R1#sh bgp vpnv4 unicast all summary
BGP router identifier 11.11.11.11, local AS number 200
BGP table version is 53, main routing table version 53
6 network entries using 912 bytes of memory
6 path entries using 312 bytes of memory
4/4 BGP path/bestpath attribute entries using 528 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1800 total bytes of memory
BGP activity 19/10 prefixes, 30/21 paths, scan interval 60 secs

Neighbor     V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
6.6.6.6 4   200   29   30    53    0    0 00:20:47     2
22.22.22.22 4   200   28   33    53    0    0 00:20:45     2

R1#sh bgp vpnv4 unicast all
BGP table version is 53, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
  r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network   Next Hop     Metric LocPrf Weight Path
Route Distinguisher: 200:1 (default for vrf ABC)
*> 172.1.17.0/24    0.0.0.0   0 32768 ?
*>i172.1.28.0/24    22.22.22.22   0    100   0 ?
*>i172.1.106.0/24   6.6.6.6   0    100   0 ?
*> 172.7.7.7/32 172.1.17.7    1 32768 ?
*>i172.8.8.8/32 22.22.22.22   1    100   0 ?
*>i172.10.10.10/32  6.6.6.6   1    100   0 ?   0 32768 i




November 2019

S M T W T F S
     12
3456789
10111213141516
171819 20 212223
24252627282930

Recent Entries

Recent Comments

Tags

    Search My Blog

    Categories

    Organization

    Community

    Downloads

    Test Providers

    Site Info


    Go to top