Jump to content






Photo - - - - -

MPLS QoS Part #2

Posted by MSSK , 26 July 2013 · 3,200 views

MPLS QoS Part #2 Now, let us choose three applications: TELNET, TFTP and ICMP
We will configure CE routers to assign these applications precedence values as they are leaving toward the MPLS backbone

R4

ip access-list extended TELNET
permit tcp any any eq telnet
permit tcp any eq telnet any

ip access-list extended TFTP
permit udp any any eq 69

ip access-list extended ICMP
permit icmp any any

class-map ICMP_CLASS
match access-group name ICMP
class-map TFTP_CLASS
match access-group name TFTP
class-map TELNET_CLASS
match access-group name TELNET

policy-map MARK
class TELNET_CLASS
  set ip precedence 1
class TFTP_CLASS
  set ip precedence 2
class ICMP_CLASS
  set ip precedence 3
class class-default
  set ip precedence 6

interface FastEthernet1/0
service-policy output MARK

R5

ip access-list extended TELNET
permit tcp any any eq telnet
permit tcp any eq telnet any

ip access-list extended TFTP
permit udp any any eq 69

ip access-list extended ICMP
permit icmp any any

class-map ICMP_CLASS
match access-group name ICMP
class-map TFTP_CLASS
match access-group name TFTP
class-map TELNET_CLASS
match access-group name TELNET

policy-map MARK
class TELNET_CLASS
  set ip precedence 1
class TFTP_CLASS
  set ip precedence 2
class ICMP_CLASS
  set ip precedence 3
class class-default
  set ip precedence 6

interface FastEthernet1/0
service-policy output MARK


To enable telnet access

R6, R7

line vty 0 4
password cisco
login

enable secret cisco

For TFTP R7 will be the server and R6 will be the client

R7

tftp-server nvram:underlying-config

R4#show policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy output: MARK

    Class-map: TELNET_CLASS (match-all)  
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: access-group name TELNET
  QoS Set
    precedence 1
  Packets marked 0

    Class-map: TFTP_CLASS (match-all)  
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: access-group name TFTP
  QoS Set
    precedence 2
  Packets marked 0

    Class-map: ICMP_CLASS (match-all)  
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: access-group name ICMP
  QoS Set
    precedence 3
  Packets marked 0

    Class-map: class-default (match-any)  
  3 packets, 495 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: any
  QoS Set
    precedence 6
  Packets marked 0

R4#show policy-map interface fastEthernet 1/0 | inc Class|marked
    Class-map: TELNET_CLASS (match-all)  
  Packets marked 0
    Class-map: TFTP_CLASS (match-all)  
  Packets marked 0
    Class-map: ICMP_CLASS (match-all)  
  Packets marked 0
    Class-map: class-default (match-any)  
  Packets marked 0

R6#ping 7.7.7.7 repeat 20
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 44/71/128 ms

R6#telnet 7.7.7.7
Trying 7.7.7.7 ... Open

User Access Verification

Password:
R7>en
Password:
R7#exit

[Connection to 7.7.7.7 closed by foreign host]

R6#copy tftp://7.7.7.7/underlying-config null:
Accessing tftp://7.7.7.7/underlying-config...
Loading underlying-config from 7.7.7.7 (via FastEthernet1/0): !
[OK - 233 bytes]

233 bytes copied in 0.252 secs (925 bytes/sec)

R4#show policy-map interface fastEthernet 1/0 | inc Class|marked
    Class-map: TELNET_CLASS (match-all)  
  Packets marked 34
    Class-map: TFTP_CLASS (match-all)  
  Packets marked 4
    Class-map: ICMP_CLASS (match-all)  
  Packets marked 20
    Class-map: class-default (match-any)  
  Packets marked 8

R5#show policy-map interface fastEthernet 1/0 | inc Class|marked
    Class-map: TELNET_CLASS (match-all)  
  Packets marked 27
    Class-map: TFTP_CLASS (match-all)  
  Packets marked 0
    Class-map: ICMP_CLASS (match-all)  
  Packets marked 20
    Class-map: class-default (match-any)  
  Packets marked 8

As we can see the count appears, but for TFTP traffic it’s a one way as one of the routers is acting as a server and the other one is acting as a client

Now, let us implement some queuing and policing
Let us focus on ICMP traffic, we will configure a 3 rate policer as below (as traffic is leaving toward the MPLS backbone)

Conform action: transmit
Exceed action: set the MPLS EXP bit to 5
Violate action: drop

R1

class-map EXP_CLASS
match mpls experimental topmost 3

policy-map EXP_POLICY
class EXP_CLASS
  police 64000 conform-action transmit  exceed-action set-mpls-exp-topmost-transmit 5 violate-action drop

interface FastEthernet1/0
service-policy output EXP_POLICY

R1#sh policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy output: EXP_POLICY

    Class-map: EXP_CLASS (match-all)  
  20 packets, 2440 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: mpls experimental topmost 3
  police:
  cir 64000 bps, bc 2000 bytes, be 2000 bytes
    conformed 20 packets, 2440 bytes; actions:
  transmit
exceeded 0 packets, 0 bytes; actions:
  set-mpls-exp-topmost-transmit 5
    violated 0 packets, 0 bytes; actions:
  drop
conformed 0000 bps, exceeded 0000 bps, violated 0000 bps

    Class-map: class-default (match-any)  
  56172 packets, 21716570 bytes
  5 minute offered rate 2000 bps, drop rate 0000 bps
  Match: any

Now, let us configure on the P router (R3) MQC in order to check for the policy we configured

R3

class-map match-all PRECEDENCE_6
match mpls experimental topmost 6
class-map match-all PRECEDENCE_5
match mpls experimental topmost 5
class-map match-all PRECEDENCE_3
match mpls experimental topmost 3
class-map match-all PRECEDENCE_2
match mpls experimental topmost 2
class-map match-all PRECEDENCE_1
match mpls experimental topmost 1

policy-map MATCH
class PRECEDENCE_1
class PRECEDENCE_2
class PRECEDENCE_3
class PRECEDENCE_6
class PRECEDENCE_5

interface FastEthernet1/0
ip address 192.1.13.3 255.255.255.0
ip router isis 1
speed 100
duplex full
mpls ip
service-policy input MATCH

Now , we will generate some traffic from R6 toward R7 (we will influence the size of ICMP packets in order to see the dropped packets)

R6#ping 7.7.7.7 repeat 20 size 1600
Type escape sequence to abort.
Sending 20, 1600-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!.!!!.!!!.!!.!!!.!
Success rate is 75 percent (15/20), round-trip min/avg/max = 76/88/108 ms

R1#sh policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy output: EXP_POLICY

    Class-map: EXP_CLASS (match-all)  
  40 packets, 33280 bytes
  5 minute offered rate 1000 bps, drop rate 0000 bps
  Match: mpls experimental topmost 3
  police:
  cir 64000 bps, bc 2000 bytes, be 2000 bytes
    conformed 30 packets, 18060 bytes; actions:
  transmit
exceeded 5 packets, 7610 bytes; actions:
  set-mpls-exp-topmost-transmit 5
    violated 5 packets, 7610 bytes; actions:
  drop
conformed 1000 bps, exceeded 1000 bps, violated 1000 bps

    Class-map: class-default (match-any)  
  17 packets, 6964 bytes
  5 minute offered rate 2000 bps, drop rate 0000 bps
  Match: any

R3#show policy-map interface fastEthernet 1/0 | inc Class|packets
    Class-map: PRECEDENCE_1 (match-all)  
  0 packets, 0 bytes
    Class-map: PRECEDENCE_2 (match-all)  
  0 packets, 0 bytes
    Class-map: PRECEDENCE_3 (match-all)  
  40 packets, 18480 bytes
    Class-map: PRECEDENCE_6 (match-all)  
  0 packets, 0 bytes
    Class-map: PRECEDENCE_5 (match-all)  
  10 packets, 7820 bytes
    Class-map: class-default (match-any)  
  10 packets, 725 bytes

As we can see the PRECEDENCE_5 class is counting

Now, let us move our policy toward the customer side (toward R5), R5 does not understand EXP bit as the disposition happens at its PE router: R2, so how we will apply the same policy and queuing mechanism? We will configure what so called QoS groups

R2

class-map match-all INPUT_CLASS
match mpls experimental topmost 3

policy-map INPUT_POLICY
class INPUT_CLASS
  set qos-group 3

interface FastEthernet1/0
service-policy input INPUT_POLICY

class-map match-all OUTPUT_CLASS
match qos-group 3

policy-map OUTPUT_POLICY
class OUTPUT_CLASS
  police 64000 conform-action transmit  exceed-action set-mpls-exp-topmost-transmit 5 violate-action drop

interface FastEthernet1/1
service-policy output OUTPUT_POLICY

R6#ping 7.7.7.7 repeat 20 size 1600
Type escape sequence to abort.
Sending 20, 1600-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!.!!.!!.!!.!!.!!!.
Success rate is 70 percent (14/20), round-trip min/avg/max = 64/87/128 ms

R1#sh policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy output: EXP_POLICY

    Class-map: EXP_CLASS (match-all)  
  40 packets, 33280 bytes
  5 minute offered rate 3000 bps, drop rate 1000 bps
  Match: mpls experimental topmost 3
  police:
  cir 64000 bps, bc 2000 bytes, be 2000 bytes
    conformed 28 packets, 19156 bytes; actions:
  transmit
exceeded 9 packets, 9558 bytes; actions:
  set-mpls-exp-topmost-transmit 5
    violated 3 packets, 4566 bytes; actions:
  drop
conformed 2000 bps, exceeded 1000 bps, violated 1000 bps

    Class-map: class-default (match-any)  
  25 packets, 10724 bytes
  5 minute offered rate 1000 bps, drop rate 0000 bps
  Match: any

R4#sh policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy output: MARK

    Class-map: TELNET_CLASS (match-all)  
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: access-group name TELNET
  QoS Set
    precedence 1
  Packets marked 0

    Class-map: TFTP_CLASS (match-all)  
  0 packets, 0 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: access-group name TFTP
  QoS Set
    precedence 2
  Packets marked 0

    Class-map: ICMP_CLASS (match-all)  
  40 packets, 32960 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: access-group name ICMP
  QoS Set
    precedence 3
  Packets marked 40

    Class-map: class-default (match-any)  
  12 packets, 1380 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: any
  QoS Set
    precedence 6
  Packets marked 2

R1#sh policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy output: EXP_POLICY

    Class-map: EXP_CLASS (match-all)  
  40 packets, 33280 bytes
  5 minute offered rate 3000 bps, drop rate 1000 bps
  Match: mpls experimental topmost 3
  police:
  cir 64000 bps, bc 2000 bytes, be 2000 bytes
    conformed 28 packets, 19156 bytes; actions:
  transmit
exceeded 9 packets, 9558 bytes; actions:
  set-mpls-exp-topmost-transmit 5
    violated 3 packets, 4566 bytes; actions:
  drop
conformed 2000 bps, exceeded 1000 bps, violated 1000 bps

    Class-map: class-default (match-any)  
  25 packets, 10724 bytes
  5 minute offered rate 1000 bps, drop rate 0000 bps
  Match: any

R2#sh policy-map interface fastEthernet 1/0
FastEthernet1/0

  Service-policy input: INPUT_POLICY

    Class-map: INPUT_CLASS (match-all)  
  54 packets, 29212 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: mpls experimental topmost 3
  QoS Set
    qos-group 3
  Packets marked 54

    Class-map: class-default (match-any)  
  33 packets, 2430 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: any

R2#sh policy-map interface fastEthernet 1/1
FastEthernet1/1

  Service-policy output: OUTPUT_POLICY

    Class-map: OUTPUT_CLASS (match-all)  
  54 packets, 28996 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: qos-group 3
  police:
  cir 64000 bps, bc 2000 bytes, be 2000 bytes
    conformed 44 packets, 15452 bytes; actions:
  transmit
exceeded 7 packets, 9074 bytes; actions:
  set-mpls-exp-topmost-transmit 5
    violated 3 packets, 4470 bytes; actions:
  drop
conformed 0000 bps, exceeded 0000 bps, violated 0000 bps

    Class-map: class-default (match-any)  
  16 packets, 1603 bytes
  5 minute offered rate 0000 bps, drop rate 0000 bps
  Match: any

Now, let us change the exceed action on R2

R2

policy-map OUTPUT_POLICY
class OUTPUT_CLASS
no police 64000 conform-action transmit  exceed-action set-mpls-exp-topmost-transmit 5 violate-action drop
police 64000 conform-action transmit  exceed-action set-prec-transmit 5 violate-action drop

Configure R7 to catch PRECEDENCE_5

R7

class-map PRECEDENCE_5
match ip precedence 5

policy-map MATCH
class PRECEDENCE_5

R6#ping 7.7.7.7 repeat 20 size 1600
Type escape sequence to abort.
Sending 20, 1600-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!.!!!.!!.!!.!!!.!!
Success rate is 75 percent (15/20), round-trip min/avg/max = 60/93/148 ms

R2#sh policy-map interface fastEthernet 1/1
FastEthernet1/1

  Service-policy output: OUTPUT_POLICY

    Class-map: OUTPUT_CLASS (match-all)  
  104 packets, 54896 bytes
  5 minute offered rate 1000 bps, drop rate 0000 bps
  Match: qos-group 3
  police:
  cir 64000 bps, bc 2000 bytes, be 2000 bytes
   conformed 44 packets, 16960 bytes; actions:
  transmit
exceeded 6 packets, 8940 bytes; actions:
  set-prec-transmit 5
    violated 0 packets, 0 bytes; actions:
  drop
conformed 0000 bps, exceeded 0000 bps, violated 0000 bps

    Class-map: class-default (match-any)  
[font=lucida sans unicode,lucida grande,sans-serif]   47 packets, 4792 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif]   5 minute offered rate 0000 bps, drop rate 0000 bps[/font]
[font=lucida sans unicode,lucida grande,sans-serif]   Match: any[/font]
[font=lucida sans unicode,lucida grande,sans-serif] [/font]
[font=lucida sans unicode,lucida grande,sans-serif]R7#show policy-map interface fastEthernet 1/0 | inc Class|packet[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    Class-map: PRECEDENCE_1 (match-all)  [/font]
[font=lucida sans unicode,lucida grande,sans-serif]   0 packets, 0 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    Class-map: PRECEDENCE_2 (match-all)  [/font]
[font=lucida sans unicode,lucida grande,sans-serif]   0 packets, 0 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    Class-map: PRECEDENCE_3 (match-all)  [/font]
[font=lucida sans unicode,lucida grande,sans-serif]   44 packets, 16960 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    Class-map: PRECEDENCE_6 (match-all)  [/font]
[font=lucida sans unicode,lucida grande,sans-serif]   3 packets, 282 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    Class-map: PRECEDENCE_5 (match-all)  [/font]
[font=lucida sans unicode,lucida grande,sans-serif]   6 packets, 8940 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    Class-map: class-default (match-any)  [/font]
[font=lucida sans unicode,lucida grande,sans-serif]   0 packets, 0 bytes[/font]
[font=lucida sans unicode,lucida grande,sans-serif] [/font]
[font=lucida sans unicode,lucida grande,sans-serif] [/font]
[font=lucida sans unicode,lucida grande,sans-serif].net File[/font]
[font=lucida sans unicode,lucida grande,sans-serif] [/font]
[font=lucida sans unicode,lucida grande,sans-serif]autostart = False[/font]
[font=lucida sans unicode,lucida grande,sans-serif]version = 0.8.3[/font]
[font=lucida sans unicode,lucida grande,sans-serif][localhost:7202][/font]
[font=lucida sans unicode,lucida grande,sans-serif]    workingdir = /tmp[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    udp = 10200[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[7200]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     image = /home/noc/Downloads/c7200-adventerprisek9-mz.152-4.S.bin[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     ghostios = True[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R5]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2005[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2505[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R2 f1/1[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/1 = R7 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = 144.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = 12.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R6]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2006[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2506[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R4 f1/1[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = -287.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = 121.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif][localhost:7203][/font]
[font=lucida sans unicode,lucida grande,sans-serif]    workingdir = /tmp[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    udp = 10300[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[7200]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     image = /home/noc/Downloads/c7200-adventerprisek9-mz.152-4.S.bin[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     ghostios = True[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R7]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2007[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2507[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R5 f1/1[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = 147.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = 130.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif][localhost:7200][/font]
[font=lucida sans unicode,lucida grande,sans-serif]    workingdir = /tmp[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    udp = 10000[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[7200]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     image = /home/noc/Downloads/c7200-adventerprisek9-mz.152-4.S.bin[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     ghostios = True[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R1]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2001[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2501[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R3 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/1 = R4 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = -177.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = -82.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R2]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2002[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2502[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R3 f1/1[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/1 = R5 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = 33.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = -77.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif][localhost:7201][/font]
[font=lucida sans unicode,lucida grande,sans-serif]    workingdir = /tmp[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    udp = 10100[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[7200]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     image = /home/noc/Downloads/c7200-adventerprisek9-mz.152-4.S.bin[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     ghostios = True[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R4]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2004[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2504[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R1 f1/1[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/1 = R6 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = -290.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = 3.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]    [[ROUTER R3]][/font]
[font=lucida sans unicode,lucida grande,sans-serif]     console = 2003[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     aux = 2503[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     slot1 = PA-2FE-TX[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/0 = R1 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     f1/1 = R2 f1/0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     x = -74.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     y = -166.0[/font]
[font=lucida sans unicode,lucida grande,sans-serif]     z = 1.0[/font]




thanks

March 2019

S M T W T F S
     12
3456789
10111213141516
17181920 21 2223
24252627282930
31      

Recent Entries

Recent Comments

Tags

    Search My Blog

    Categories

    Organization

    Community

    Downloads

    Test Providers

    Site Info


    Go to top