Jump to content


4

Cisco-Faqs


27 replies to this topic

#1 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 01:25 PM

This Thread is Created to Explain the different technologies, topics, Configuration examples, which can be from Basic level to Expert level.

The main theme of this thread is to make understand some configurations and to help you in revising different technologies for your Respective exams or OEQs if your planning for CCIE in future :)



Try to keep this Thread as informative as possible :)



P.S: Please don't post any thing not related to the thread (even greetings)

All the Best for your Exams...

Thank you

Takecare.


Thanked by 13 Members:
CCKLOVE , dyygidh , capricornboy , vishu2811 , 8heathmont , mahdi1975 , bmbcompany , cisco1988 , mateagun , bebedongo , bajantrina , brookehello , Bond007

#2 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 01:30 PM


1. Which default administrative distances are used by Cisco?

Ans:
Most routing protocols have metric structures and algorithms that are not compatible with other protocols. In a network with multiple routing protocols, the exchange of route information and the capability to select the best path across the multiple protocols are critical.

Administrative distance is the feature that routers use in order to select the best path when there are two or more different routes to the same destination from two different routing protocols. Administrative distance defines the reliability of a routing protocol. Each routing protocol is prioritized in order of most to least reliable (believable) with the help of an administrative distance value

Default Distance Values:

Connected interface -            0
Static route -                    1
EIGRP summary route -            5
eBGP -                                   20
EIGRP -                           90
IGRP -                                100
OSPF -                         110
IS-IS -                         115
RIP -                                120
EGP -                                 140
On Demand Routing (ODR) - 160
External EIGRP -                 170
iBGP -                                 200
Unknown -                         255


Thanked by 3 Members:
skitnica , chotelaldon , bajantrina

#3 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 01:44 PM

2. When does a Cisco router initiate a routing request out its interfaces?

    Ans.
A Cisco router that runs a distance vector routing protocol initiates a routing request out its interfaces if any of these conditions are met:

        *   The interface goes down.

        *   There is any change to the router global configuration command.

        *   There is any change to the metric configuration command.

        *   The clear ip route EXEC command is used.

        *   The shutdown interface configuration command is used.

        *   The router is booted.

        *   There is any change to the ip address command.

    The request is sent out to all interfaces configured for that particular protocol no matter which interface triggers the request. The request is sent out to one interface only if that is the only interface configured for the protocol.

  
Hint: You can check this behavior by turning the debug commands for the respective protocols


#4 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 01:47 PM

3.What is the difference between the ip default-gateway, ip default-network, and ip route 0.0.0.0/0 commands?

    Ans.
The ip default-gateway command is used when IP routing is disabled on the router. However, ip default-network and ip route 0.0.0.0/0 are effective when IP routing is enabled on the router and they are used to route any packets which do not have an exact route match in the routing table

Thanked by 1 Member:
adrianisccie

#5 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 01:54 PM

4. What is the difference between the two methods to create static routes?

    Ans.
There are two methods to create static routes:

        *  The ip route 10.1.1.1 255.255.255.0 eth 0/0 command generates an ARP broadcast that looks for the next-hop IP address.
        *  The ip route 10.1.1.1 255.255.255.0 172.16.1.1 command does not generate an ARP request. It keeps Layer 2 out of the routing process.



Thanked by 2 Members:
ashishjkumar , adrianisccie

#6 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 01:58 PM

5. Who does load-balancing when there are multiple links to a destination, Cisco Express Forwarding (CEF), or the routing protocol?

    Ans.
CEF does the switching of the packet based on the routing table which is being populated by the routing protocols such as EIGRP, RIP, Open Shortest Path First (OSPF), and so forth. CEF does the load-balancing once the routing protocol table has been calculated.

Thanked by 1 Member:
adrianisccie

#7 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 02:00 PM

6. How to configure frame relay switch for CCIE lab ?
Ans:
In the Cisco CCIE lab is a frame relay switch used to connect the routers and simulate a Frame Relay cloud. See the example configuration below for the configuration of this Frame Relay switch.

example configuring frame relay switch ccie:

frame-relay switching
!
!
interface Serial1/0
description Connected to Rack1R1
no ip address
encapsulation frame-relay
clockrate 64000
no fair-queue
frame-relay intf-type dce
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
frame-relay route 104 interface Serial1/4 401
frame-relay route 105 interface Serial1/5 501
frame-relay route 106 interface Serial1/5 601
frame-relay route 113 interface Serial1/3 311
!
interface Serial1/1
description Connected to Rack1R2
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial1/0 102
frame-relay route 203 interface Serial1/2 302
frame-relay route 204 interface Serial1/4 402
frame-relay route 205 interface Serial1/5 502
frame-relay route 213 interface Serial1/3 312
frame-relay route 214 interface Serial1/5 412
!
interface Serial1/2
description Connected to Rack1R3
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 112 interface Serial1/7 211
frame-relay route 301 interface Serial1/0 103
frame-relay route 302 interface Serial1/1 203
frame-relay route 304 interface Serial1/3 403
frame-relay route 305 interface Serial1/4 503
!
interface Serial1/3
description Connected to Rack1R3
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 304 interface Serial1/4 403
frame-relay route 306 interface Serial1/6 603
frame-relay route 311 interface Serial1/0 113
frame-relay route 312 interface Serial1/1 213
frame-relay route 314 interface Serial1/4 413
frame-relay route 315 interface Serial1/5 513
frame-relay route 403 interface Serial1/2 304
frame-relay route 412 interface Serial1/1 214
!
interface Serial1/4
description Connected to Rack1R4
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 401 interface Serial1/0 104
frame-relay route 402 interface Serial1/1 204
frame-relay route 403 interface Serial1/3 304
frame-relay route 405 interface Serial1/5 504
frame-relay route 406 interface Serial1/6 604
frame-relay route 413 interface Serial1/3 314
frame-relay route 503 interface Serial1/2 305
!
interface Serial1/5
description Connected to Rack1R5
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 311 interface Serial1/0 113
frame-relay route 412 interface Serial1/1 214
frame-relay route 501 interface Serial1/0 105
frame-relay route 502 interface Serial1/1 205
frame-relay route 503 interface Serial1/2 305
frame-relay route 504 interface Serial1/4 405
frame-relay route 513 interface Serial1/3 315
frame-relay route 601 interface Serial1/0 106
!
interface Serial1/6
description Connected to Rack1R6
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 51 interface Serial1/7 51
frame-relay route 100 interface Serial1/7 100
frame-relay route 101 interface Serial1/7 101
frame-relay route 201 interface Serial1/7 201
frame-relay route 301 interface Serial1/7 301
frame-relay route 401 interface Serial1/7 401
frame-relay route 601 interface Serial1/0 106
frame-relay route 603 interface Serial1/3 306
frame-relay route 604 interface Serial1/4 406
!
interface Serial1/7
description Connected to BB1
no ip address
encapsulation frame-relay
clockrate 64000
frame-relay intf-type dce
frame-relay route 51 interface Serial1/6 51
frame-relay route 100 interface Serial1/6 100
frame-relay route 101 interface Serial1/6 101
frame-relay route 201 interface Serial1/6 201
frame-relay route 211 interface Serial1/2 112
frame-relay route 301 interface Serial1/6 301
frame-relay route 401 interface Serial1/6 401

Thanked by 1 Member:
adrianisccie

#8 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 02:05 PM

7. How to configure Enhanced Object Tracking route reachability on Cisco (HSRP) ?

Ans:
example configuring object tracking route reachability

track 5 ip route 10.125.0.0/16 reachability
delay up 30
!
interface FastEthernet0/0
ip address 10.10.10.3 255.255.255.0
standby 5 preempt
standby 5 ip 10.10.10.1
standby 5 priority 110
standby 5 track 100 decrement 10

show track
show standby (brief)

#9 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 02:13 PM

8. What is Unicast Reverse Path Forwarding (uRPF)? Can a default route 0.0.0.0/0 be used to perform a uRPF check?

    Ans.
Unicast Reverse Path Forwarding, used for preventing source address spoofing, is a "look backward" ability which allows the router to check and see if any IP packet received at a router interface arrives on the best return path (return route) to the source address of the packet. If the packet was received from one of the best reverse path routes, the packet is forwarded as normal. If there is no reverse path route on the same interface from which the packet was received, the packet is dropped or forwarded, depending on whether an access control list (ACL) is specified in the ip verify unicast reverse-path list interface configuration command.

Default route 0.0.0.0/0 can not be used to perform a uRPF check. For example, if a packet with source address 10.10.10.1 comes on Serial 0 interface and the only route matching 10.10.10.1 is the default route 0.0.0.0/0 pointing out Serial 0 on the router, the uRPF check fails and it drops that packet.


Thanked by 1 Member:
adrianisccie

#10 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 02:28 PM

9.What are well known TCP / UDP port numbers PORT NUMBERS?

Ans:
The port numbers are divided into three ranges: the Well Known Ports,
the Registered Ports, and the Dynamic and/or Private Ports.

The Well Known Ports are those from 0 through 1023.

The Registered Ports are those from 1024 through 49151

The Dynamic and/or Private Ports are those from 49152 through 65535


WELL KNOWN PORT NUMBERS

The Well Known Ports are assigned by the IANA and on most systems can
only be used by system (or root) processes or by programs executed by
privileged users.

Ports are used in the TCP [RFC793] to name the ends of logical
connections which carry long term conversations. For the purpose of
providing services to unknown callers, a service contact port is
defined. This list specifies the port used by the server process as
its contact port. The contact port is sometimes called the
"well-known port".

To the extent possible, these same port assignments are used with the
UDP [RFC768].

The assigned ports use a small portion of the possible port numbers.
For many years the assigned ports were in the range 0-255. Recently,
the range for assigned ports managed by the IANA has been expanded to
the range 0-1023.


well known port list from IANA on the Internet:

http://www.iana.org/assignments/port-numbers 


#11 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 07 September 2009 - 02:37 PM

10.  I have four equal cost parallel paths to the same destination. I am doing fast switching on two links and process switching on the other two. How will the packets be routed in this situation?

    Ans.
Assume that we have four equal cost paths to some set of IP networks. Interfaces 1 and 2 fast switch (ip route-cache enabled on the interface) , 3 and 4 do not (no ip route-cache). The router first establishes the four equal cost paths in a list (path 1, 2, 3, and 4). When you do a show ip route x.x.x.x, the four "next hops" to x.x.x.x display.

    The pointer is called interface_pointer on interface 1. Interface_pointer cycles through the interfaces and routes in some orderly deterministic fashion such as 1-2-3-4-1-2-3-4-1 and so on. The output of show ip route x.x.x.x has a "*" to the left of the "next hop" that interface_pointer uses for a destination address not found in the cache. Each time that interface_pointer is used, it advances to the next interface or route.

    To illustrate the point better, consider this repeating loop:

        * A packet comes in, destined for a network serviced by the four parallel paths.

        * The router checks to see if it is in the cache. (The cache starts off empty.)

        * If it is in the cache, the router sends it to the interface stored in the cache. Otherwise, the router sends it to the interface where the interface_pointer is and moves interface_pointer to the next interface in the list.

        *If the interface over which the router just sent the packet is running route-cache, the router populates the cache with that interface ID and the destination IP address. All subsequent packets to the same destination are then switched using the route-cache entry (thus they are fast-switched).

    If there are two route-cache and two non-route-cache interfaces, there is a 50 percent probability that a uncached entry will hit an interface that caches entries, caching that destination to that interface. Over time, the interfaces running fast switching (route-cache) carry all the traffic except destinations not in the cache. This happens because once a packet to a destination is process-switched over an interface, the interface_pointer moves and points to the next interface in the list. If this interface is also process-switched, then the second packet is process-switched over the interface and the interface_pointer moves on to point to the next interface. Since there are only two process-switched interfaces, the third packet will route to fast-switched interface, which, in turn, will cache. Once cached in the IP route-cache, all the packets to the same destination will be fast-switched. Thus, there is a 50 percent probability that a uncached entry will hit an interface that caches entries, caching that destination to that interface.

    In case of a failure of a process-switched interface, the routing table is updated and you would have three equal cost paths (two fast-switched and one process-switched). Over time, the interfaces running fast switching (route-cache) carry all the traffic except destinations not in the cache. With two route-cache and one non-route-cache interfaces, there is a 66 percent probability that a uncached entry will hit an interface that caches entries, caching that destination to that interface. You can expect that the two fast switched interfaces will carry all the traffic over time.

    Similarly when a fast switched interface fails, you would have three equal cost paths, one fast-switched and two process-switched. Over time the interface running fast switching (route-cache) carries all the traffic except destinations not in cache. There is 33 percent probability that a uncached entry would hit an interface that cached entries, caching that destination to that interface. You can expect that the single interface with caching enabled will carry all of the traffic over time in this case.

    If no interface is running route-cache, the router round-robins the traffic on a packet-by-packet basis.

    In conclusion, if multiple equal paths to a destination exist, some are process-switched while others are fast switched, then over time most of the traffic will be carried by the fast-switched interfaces only. The load balancing thus attained is not optimum and might in some cases lower the performance. Therefore, it is recommended that you do one of the following:

        * Either have all route-cache or no route-cache on all interfaces in parallel paths.

          or

        * Expect that the interfaces with caching enabled will carry all of the traffic over time.


#12 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 08 September 2009 - 10:02 AM

11.What is synchronization, and how does it influence BGP routes installed in the IP routing table?

    Ans.
If your AS passes traffic from another AS to a third AS, BGP should not advertise a route before all routers in your AS learn about the route via IGP. BGP waits until IGP propagates the route within the AS and then advertises it to external peers. A BGP router with synchronization enabled does not install iBGP learned routes into its routing table if it is not able to validate those routes in its IGP. Issue the no synchronization command under router bgp in order to disable synchronization. This prevents BGP from validating iBGP routes in IGP.

#13 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 08 September 2009 - 10:04 AM

12.Does the route reflector change the next hop attribute of a reflected prefix?

    Ans.
By default, the next hop attribute is not changed when a prefix is reflected by route reflector. However, you can issue the neighbor next-hop-self command in order to change the attribute of the next hop for prefixes reflected from an eBGP peer to any route reflector client.

#14 bondprat

bondprat

    Advanced Member

  • Members
  • PipPipPip
  • 69 posts
  • 30 thanks

Posted 08 September 2009 - 10:06 AM

13. What is an autonomous system (AS) number and how do I obtain one?

    Ans.
AS numbers are globally unique numbers that are used to identify ASes, and which enable an AS to exchange exterior routing information between neighboring ASes. An AS is a connected group of IP networks that adhere to a single and clearly defined routing policy.

    There are a limited number of available AS numbers. Therefore, it is important to determine which sites require unique AS numbers and which do not. Sites that do not require a unique AS number should use one or more of the AS numbers reserved for private use, which are in the range from 64512 to 65535.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top