Jump to content


1
[Req]

vQFX?



32 replies to this topic

#15 junosexpert

junosexpert

    Advanced Member

  • Members
  • PipPipPip
  • 184 posts
  • 9816 thanks
  • LocationJunos OS CLI

Posted 18 August 2015 - 01:20 PM

This is not a vQFX, BTW so far I didn't hear about any vQFX. Please share the link or doc that say something about vQFX. the shared image is an Olive of JunOS 15.2

[edit]
[email protected]# run show system software detail | match platform
Information for jplatform-ex92xx:
JUNOS platform Software Suite [15.2I20150605_0839_laxng]
JUNOS platform Software Release


[edit]
[email protected]# run show version | match model
Model: olive

[edit]
[email protected]# run show chassis hardware
error: Unrecognized command (chassis-control)



[edit]
[email protected]# run show system boot-messages | match ""M/T"|MX|EX|SRX|QFX"
WARNING: WITNESS option enabled, expect reduced performance.
  Features=0x78bfbf9<FPU,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
Security policy loaded: Junos MAC/veriexec (mac_veriexec)
MAC/veriexec fingerprint module loaded: SHA256
MAC/veriexec fingerprint module loaded: SHA1
Initializing M/T/EX platform properties ..
psm0: model IntelliMouse Explorer, device ID 4
Setting up M/T interface operations and attributes
Kernel thread "wkupdaemon" (pid 43) exited prematurely.

#16 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 18 August 2015 - 02:12 PM

View Postnicolaus, on 18 August 2015 - 12:23 PM, said:

I don't think it's a QFX VM follow this cli output

Model:olive

I noticed that, too. Did Olive ever make it up to v15.2?  It would be awesome if someone else would link to another vQFX image, so we could compare.

#17 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 18 August 2015 - 02:15 PM

View Postjunosexpert, on 18 August 2015 - 01:20 PM, said:

This is not a vQFX, BTW so far I didn't hear about any vQFX. Please share the link or doc that say something about vQFX. the shared image is an Olive of JunOS 15.2


vQFX is in a closed beta program. I had that confirmed by a Juniper sales rep I spoke to.  I also asked about if a vEX project existed, but got no answer.

I guess someone could always rename an Olive file  jinstall-vqfx500-15.2l20150605_0839_laxng-domestic.img to fool everybody, but that would just seem silly.

Edited by HermanToothrot, 18 August 2015 - 02:35 PM.


#18 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 18 August 2015 - 02:55 PM

I suppose if you have an account rep with Juniper junosexpert (I don't), you could ask them to confirm it.  A pre-sales Juniper engineer was supposed to contact me, but they haven't yet. Kinda like the Alcatel-Lucent reps blew me off a few months ago, since I just wanted to license sros-vm.qcow2 for self-learning.  

Considering every CLEC I've installed equipment in had at least 2 massive AL Service Routers, and I'd love to get a full-time job for another ISP, this is something I want to learn how to use.

*EDIT*

I went ahead and posted a question in the J-Net forums, asking if they'd confirm the existence vQFX or even vEX.  If used MX/QFX/EX equipment weren't so gotdanged expensive, I'd just buy the gear.  Even used Arista switches run in the $9K-$10K range I found a 7100 on ebay for $2500, so thank gawd for the existence of vEOS.

The cheapest prices I was quoted for a used, refurbished MX5 was $8K, and $35K for a QFX-3500, so I really hope that vQFX does in fact exist, and is coming out soon. Used EX-2200's are only $400, but required an expensive license to do layer3.  That's bull-pucky, since I picked up a multilayer Cisco 3550 for $40.

Edited by HermanToothrot, 18 August 2015 - 06:11 PM.


#19 holodec

holodec

    Newbie

  • Members
  • Pip
  • 0 posts
  • 161 thanks

Posted 19 August 2015 - 01:51 AM

Guys,
I don`t understand why do you have any problem to boot this vqfx image. I just did it by using latest GNS3 version and qemu.

#20 bironhudo

bironhudo

    Junior Member

  • Members
  • PipPip
  • 1 posts
  • 2375 thanks

Posted 19 August 2015 - 03:05 AM

View Postholodec, on 19 August 2015 - 01:51 AM, said:

Guys,
I don`t understand why do you have any problem to boot this vqfx image. I just did it by using latest GNS3 version and qemu.

There is no problem to boot it. The problem is after booting no interface ge-* is showed, only em*. That is a expected behaviour because it happens in vMX.

#21 junosexpert

junosexpert

    Advanced Member

  • Members
  • PipPipPip
  • 184 posts
  • 9816 thanks
  • LocationJunos OS CLI

Posted 19 August 2015 - 04:10 AM

View Postbironhudo, on 19 August 2015 - 03:05 AM, said:

There is no problem to boot it. The problem is after booting no interface ge-* is showed, only em*. That is a expected behaviour because it happens in vMX.

This is not even vMX but the Olive!

Thanked by 1 Member:
nicolaus

#22 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 19 August 2015 - 02:46 PM

View Postjunosexpert, on 19 August 2015 - 04:10 AM, said:

This is not even vMX but the Olive!

I've asked about it on the J-net forums, and haven't heard a peep.  Which is strange, because I've been told that vQFX exists from about 20 different people, and none of them have steered me wrong in the past.

This is getting curiouser and curiouser...

#23 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 19 August 2015 - 02:49 PM

View Postbironhudo, on 19 August 2015 - 03:05 AM, said:

There is no problem to boot it. The problem is after booting no interface ge-* is showed, only em*. That is a expected behaviour because it happens in vMX.

Something strange  I noticed was that with different beta versions of vMX, some only show em interfaces, while 14.1.R1.10 shows ge-0/0/x interfaces. No clue what the deal is there. Some of the ones from the baidu link posted earlier won't even ping each other.

#24 Kravnik

Kravnik

    Junior Member

  • Members
  • PipPip
  • 4 posts
  • 4 thanks

Posted 19 August 2015 - 02:59 PM

this is not a vMX image, so don't expect to see ge-x/y/z interfaces. Only em interfaces are functional in Olive image.

#25 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 19 August 2015 - 03:14 PM

View PostKravnik, on 19 August 2015 - 02:59 PM, said:

this is not a vMX image, so don't expect to see ge-x/y/z interfaces. Only em interfaces are functional in Olive image.


jinstall-vmx-14.1R4.8-domestic.img
jinstall-vmx-14.1R3.5-domestic.img

both show model vmx, and neither of those show ge-x/y/z interfaces with run show interfaces terse either (just em interfaces), so take that for what it's worth.  jinstall-14.1.R1.10-domestic is the only one I have that shows ge-x/y/z interfaces, like it should.

I tried connecting two instances of each image (in Qemu) together, and set interfaces ge-0/0/0 unit 0 family inet address 10.10.10.x/24 took, but they couldn't ping each other, and the ge-0/0/0 interfaces didn't show up when I re-ran sh int terse.

Edited by HermanToothrot, 19 August 2015 - 03:17 PM.


Thanked by 1 Member:
siavash2

#26 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 19 August 2015 - 03:25 PM

View Postholodec, on 19 August 2015 - 01:51 AM, said:

Guys,
I don`t understand why do you have any problem to boot this vqfx image. I just did it by using latest GNS3 version and qemu.

The issue isn't booting it, it's whether or not it's just an Olive 15.2 that someone re-named to make it look like a vQFX image..

#27 bironhudo

bironhudo

    Junior Member

  • Members
  • PipPip
  • 1 posts
  • 2375 thanks

Posted 19 August 2015 - 04:11 PM

View PostHermanToothrot, on 19 August 2015 - 03:25 PM, said:

The issue isn't booting it, it's whether or not it's just an Olive 15.2 that someone re-named to make it look like a vQFX image..

I have asked to someone else that works at Juniper TAC and he said there is no vQFX.

Anyway the image shared by Herman Toothrot is good because it has a low RAM footprint, so it's good to deploy it as CE router in complex topologies. For example, I was able to run it with only 256MB.

Thanked by 1 Member:
HermanToothrot

#28 HermanToothrot

HermanToothrot

    Member

  • Members
  • PipPip
  • 32 posts
  • 17369 thanks
  • LocationMonkey Island

Posted 19 August 2015 - 04:21 PM

View Postbironhudo, on 19 August 2015 - 04:11 PM, said:

I have asked to someone else that works at Juniper TAC and he said there is no vQFX.

Anyway the image shared by Herman Toothrot is good because it has a low RAM footprint, so it's good to deploy it as CE router in complex topologies. For example, I was able to run it with only 256MB.

Huh. Guess the sales rep lied to me, and the other folks that told me it existed were wrong. Wouldn't be the first time I was fed bad information.  *shrug*  

Still, it would be kickass if something like vQFX or vEX existed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top