Jump to content


1
[Req]

Looking for vSRX 15.X



17 replies to this topic

#1 Archx91

Archx91

    Advanced Member

  • Members
  • PipPipPip
  • 97 posts
  • 2019 thanks

Posted 09 September 2015 - 07:10 PM

Dear colleagues, I've been looking for vSRX 15.X and I haven't found a image that works on UNL.

So far, I got this "media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk" which was extracted from this "media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova" file. On UNL after setting up this image, when I play it just stays with a blank screen even though the play icon says it's running.

If anyone could share a 15.X vsrx image that works on UNL it would be totally appreciated. Thanks it means a lot to me.

Cheers.


Thanked by 1 Member:
sj3

#2 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 10 September 2015 - 01:29 AM

Hi Archx91, I used the media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk" which was extracted from this "media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova" file. I created /opt/unetlab/addons/qemu/vsrx-vmdisk-15.1X49-D15.4 directory....and moved the hda.qcow2 file to that directory.  Then I created a lab, added two  nodes, the image shows as win-7-vsrx-15.1X49, I am using 2 cpu, 4096 mb and the console is vnc.  I hope this helps.
tester99, proud to be a member of IT Certification Forum since Oct 2008.

#3 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 10 September 2015 - 01:32 AM

correction......when I used /opt/unetlab/addons/qemu/vsrx-vmdisk-15.1X49-D15.4 directory it did not work.  So I did the following:

I created /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49 directory....and moved the hda.qcow2 file to that directory.  Then I created a lab, added two  nodes, the image shows as win-7-vsrx-15.1X49, I am using 2 cpu, 4096 mb and the console is vnc.  I hope this helps.
tester99, proud to be a member of IT Certification Forum since Oct 2008.

#4 npatel007

npatel007

    CCIE Security

  • Banned
  • PipPipPip
  • 745 posts
  • 22004 thanks

Posted 10 September 2015 - 04:57 AM

View Posttester99, on 10 September 2015 - 01:32 AM, said:

correction......when I used /opt/unetlab/addons/qemu/vsrx-vmdisk-15.1X49-D15.4 directory it did not work.  So I did the following:

I created /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49 directory....and moved the hda.qcow2 file to that directory.  Then I created a lab, added two  nodes, the image shows as win-7-vsrx-15.1X49, I am using 2 cpu, 4096 mb and the console is vnc.  I hope this helps.



win-7-vsrx-15.1X49 , may i ask question why naming convention required as win-7 . as per the unetlab given it should be ['vsrx', 'Juniper vSRX'] as naming convention

Thanked by 1 Member:
moloh

#5 Archx91

Archx91

    Advanced Member

  • Members
  • PipPipPip
  • 97 posts
  • 2019 thanks

Posted 10 September 2015 - 01:56 PM

I tried this win-7 magic thing but turns out it didn't work at all. @tester99, could you elaborate on how exactly I should do this?

I mean, my UNL directory structure looks like this:


[email protected]:/opt/unetlab/addons/qemu# ls -lah
total 36K
drwxr-xr-x 9 root root 4.0K Sep 10 14:42 .
drwxr-xr-x 5 root root 4.0K Oct 15  2014 ..
drwxr-xr-x 2 root root 4.0K Aug 28 17:23 vmx-14.1R1.10-domestic
drwxr-xr-x 2 root root 4.0K Aug 28 14:12 vsrx-12.1X44-D10.4-domestic
drwxr-xr-x 2 root root 4.0K Sep  9 19:39 win-7-vsrx-15.1X49-D15.4-domestic
[email protected]:/opt/unetlab/addons/qemu#

When I open UNL it only finds the vsrx-12.1X44 image, I guess this win-7 thing messed up the path the software was supposed to search.

I appreciate if you could guide us further here, thanks a lot man.

#6 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 11 September 2015 - 02:56 AM

Hi Archx91,

Let me know if this works for you, here is the procedure.

Procedure for adding "juniper-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova" to unl

From directory /tmp

tar xf media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova

/opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk hda.qcow2

mkdir -p /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49

mv hda.qcow2 /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49

Clean and fix permissions:
# cd ..
# rm -rf tmp

# /opt/unetlab/wrappers/unl_wrapper -a fixpermissions

Default username is “root” without password.

-------

Then I created a lab, added two  nodes, the image shows as win-7-vsrx-15.1X49, I am using 2 cpu, 4096 mb

and the console is vnc.  I hope this helps.
tester99, proud to be a member of IT Certification Forum since Oct 2008.

Thanked by 1 Member:
Archx91

#7 Archx91

Archx91

    Advanced Member

  • Members
  • PipPipPip
  • 97 posts
  • 2019 thanks

Posted 11 September 2015 - 01:37 PM

Hi tester, first of all, thanks a lot for this detailed guide you provided. I did exactly how you told me, but it turns out when I fire up UNL it doesn't show this vSRX "win-7" image (see the attachment):

[email protected]:~/iso_ovas_vms# cd vsrx/
[email protected]:~/iso_ovas_vms/vsrx# ls
junos-vsrx-12.1X44-D10.4-domestic.ova
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova
[email protected]:~/iso_ovas_vms/vsrx# mkdir tmp
[email protected]:~/iso_ovas_vms/vsrx# mv media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova tmp/
[email protected]:~/iso_ovas_vms/vsrx# cd tmp/
[email protected]:~/iso_ovas_vms/vsrx/tmp# ls
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova
[email protected]:~/iso_ovas_vms/vsrx/tmp# tar xf media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova
[email protected]:~/iso_ovas_vms/vsrx/tmp# ls
certchain.pem
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.cert
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.mf
media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ovf
[email protected]:~/iso_ovas_vms/vsrx/tmp# /opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk hda.qcow2
[email protected]:~/iso_ovas_vms/vsrx/tmp# mkdir -p /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49
[email protected]:~/iso_ovas_vms/vsrx/tmp# mv hda.qcow2 /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49
[email protected]:~/iso_ovas_vms/vsrx/tmp# cd ..
[email protected]:~/iso_ovas_vms/vsrx# ls
junos-vsrx-12.1X44-D10.4-domestic.ova  tmp
[email protected]:~/iso_ovas_vms/vsrx# rm -rf tmp/
[email protected]:~/iso_ovas_vms/vsrx# /opt/unetlab/wrappers/unl_wrapper -a fixpermissions

The result was this (only my old vSRX shows up):  Posted Image


Where did you get this image from? Maybe the one that I've got here is corrupted or something? I'd appreciate if you could tell us where you get it from. Thanks again man.

Another thing, why is it necessary to put this win-7 string? wouldn't it mess up UNL directories and that's why it doesn't show up? Thanks if you could elaborate on this matter.

#8 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 12 September 2015 - 12:12 AM

Hi Archx91,

I got it from here:




http://www.4shared.com/rar/plL2ZbTgba/media-srx-ffp-vsrx-vmdisk-151X.html
http://www.4shared.com/rar/4NLOJGPYba/media-srx-ffp-vsrx-vmdisk-151X.html


Someone posted this, not me and both of them work.  I used the win-7 directory for pure experimentation, just looking at the what ifs and it worked.  It also works for BackTrack5.
tester99, proud to be a member of IT Certification Forum since Oct 2008.

#9 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 12 September 2015 - 12:33 AM

another post...all credit goes to telmetrik..


vSRX 15.1X49 VmWare images
Started By telemetrik , Yesterday, 02:11 PM

Posted Yesterday, 02:11 PM
Magnet URI:
Hidden Content

magnet:?xt=urn:btih:67E9A04E4848161AD4DAA35539A7154492B374A7&dn=vSRX&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.publicbt.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.ccc.de%3a80%2fannounce

This is the other download I used....I only used these two sources.
tester99, proud to be a member of IT Certification Forum since Oct 2008.

Thanked by 3 Members:
ajnajn , mobeidat , fatanu

#10 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 12 September 2015 - 03:21 AM

Hi Archx91,

I see what the problem is you are adding Juniper vsrx but, the directory you created will be in the win-7-vsrx-15.1X49 directory, so when you add node choose "Windows" and from the drop down and choose the win-7-vsrx-15.1X49.



I created a lab, added two nodes, the image shows as win-7-vsrx-15.1X49, I am using 2 cpu, 4096 mb and the console is vnc.
tester99, proud to be a member of IT Certification Forum since Oct 2008.

#11 npatel007

npatel007

    CCIE Security

  • Banned
  • PipPipPip
  • 745 posts
  • 22004 thanks

Posted 12 September 2015 - 06:37 AM

View Posttester99, on 12 September 2015 - 12:12 AM, said:

Hi Archx91, I got it from here: http://www.4shared.com/rar/plL2ZbTgba/media-srx-ffp-vsrx-vmdisk-151X.html http://www.4shared.com/rar/4NLOJGPYba/media-srx-ffp-vsrx-vmdisk-151X.html Someone posted this, not me and both of them work. I used the win-7 directory for pure experimentation, just looking at the what ifs and it worked. It also works for BackTrack5.

View PostArchx91, on 11 September 2015 - 01:37 PM, said:

Hi tester, first of all, thanks a lot for this detailed guide you provided. I did exactly how you told me, but it turns out when I fire up UNL it doesn't show this vSRX "win-7" image (see the attachment): [email protected]:~/iso_ovas_vms# cd vsrx/ [email protected]:~/iso_ovas_vms/vsrx# ls junos-vsrx-12.1X44-D10.4-domestic.ova media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova [email protected]:~/iso_ovas_vms/vsrx# mkdir tmp [email protected]:~/iso_ovas_vms/vsrx# mv media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova tmp/ [email protected]:~/iso_ovas_vms/vsrx# cd tmp/ [email protected]:~/iso_ovas_vms/vsrx/tmp# ls media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova [email protected]:~/iso_ovas_vms/vsrx/tmp# tar xf media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova [email protected]:~/iso_ovas_vms/vsrx/tmp# ls certchain.pem media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.cert media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.mf media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ovf [email protected]:~/iso_ovas_vms/vsrx/tmp# /opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk hda.qcow2 [email protected]:~/iso_ovas_vms/vsrx/tmp# mkdir -p /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49 [email protected]:~/iso_ovas_vms/vsrx/tmp# mv hda.qcow2 /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49 [email protected]:~/iso_ovas_vms/vsrx/tmp# cd .. [email protected]:~/iso_ovas_vms/vsrx# ls junos-vsrx-12.1X44-D10.4-domestic.ova tmp [email protected]:~/iso_ovas_vms/vsrx# rm -rf tmp/ [email protected]:~/iso_ovas_vms/vsrx# /opt/unetlab/wrappers/unl_wrapper -a fixpermissions The result was this (only my old vSRX shows up): Posted Image Where did you get this image from? Maybe the one that I've got here is corrupted or something? I'd appreciate if you could tell us where you get it from. Thanks again man. Another thing, why is it necessary to put this win-7 string? wouldn't it mess up UNL directories and that's why it doesn't show up? Thanks if you could elaborate on this matter.


Hello team i have tested and working fine under srx category  i have used this  vsrx-15.1X49-D15.4-domestic as name convention

here is output
Posted Image



One prob i am facing issue its not starting i tried using both telnet and vnc with 4096 ram  as suggested by tester , Any idea what can be done , or how much time we need to wait for booting i waiting for 3 min but nothing show up on screen

edit : it starts booting after adding under win7 but after boot immediately it sends term signal
here is screen i am getting

Posted Image

Edited by npatel007, 12 September 2015 - 07:04 AM.


#12 snegurka123

snegurka123

    Advanced Member

  • Members
  • PipPipPip
  • 102 posts
  • 3558 thanks

Posted 12 September 2015 - 06:47 AM

View Posttester99, on 11 September 2015 - 02:56 AM, said:

Hi Archx91,

Let me know if this works for you, here is the procedure.

Procedure for adding "juniper-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova" to unl

From directory /tmp

tar xf media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4.ide.ova

/opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 media-srx-ffp-vsrx-vmdisk-15.1X49-D15.4-disk1.vmdk hda.qcow2

mkdir -p /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49

mv hda.qcow2 /opt/unetlab/addons/qemu/win-7-vsrx-15.1X49

Clean and fix permissions:
# cd ..
# rm -rf tmp

# /opt/unetlab/wrappers/unl_wrapper -a fixpermissions

Default username is “root” without password.

-------

Then I created a lab, added two  nodes, the image shows as win-7-vsrx-15.1X49, I am using 2 cpu, 4096 mb

and the console is vnc.  I hope this helps.

doesn't work

did you test on bare metal or esxi?
did you do any other changes to the template?
for me image boot to linux and hang

#13 npatel007

npatel007

    CCIE Security

  • Banned
  • PipPipPip
  • 745 posts
  • 22004 thanks

Posted 12 September 2015 - 07:13 AM

View Postsnegurka123, on 12 September 2015 - 06:47 AM, said:

doesn't work

did you test on bare metal or esxi?
did you do any other changes to the template?
for me image boot to linux and hang

seems same for me

#14 tester99

tester99

    Junior Member

  • Members
  • PipPip
  • 2 posts
  • 5 thanks

Posted 13 September 2015 - 12:19 AM

Hi Archx91,

I will show you snapshots once I got word installed and show you that it works.  It is not terminating for me, it is up and stable.
tester99, proud to be a member of IT Certification Forum since Oct 2008.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top