Jump to content


0

Update SCCM 2007 to SCCM 2007 SP1 - Step 1


No replies to this topic

#1 t-zwck

t-zwck

    .::GhostInTheShell::.

  • Super Moderators
  • 759 posts
  • 9803 thanks

Posted 16 July 2009 - 07:23 AM

This guide was done on a Windows 2003 Server (sp2) running SCCM 2007 which in turn was from SMS 2003.

As a result, your results may vary, if they do, post them here.



Part 1. Run the Pre-requisite checks and fix the warnings/errors reported.


First of all download the http://www.microsoft.com/downloads/details.aspx?FamilyID=5aae62e8-4b7f-4af7-be01-aefaa4bf059a&DisplayLang=en and then run the EXE file which will unzip it to a folder of your choice (I chose to call the folder sccm2007sp1)

Attached File  1post-1-1218226690.jpg   16.87K   35 downloads

Once unzipped you can burn that to a DVD or run the splash.hta file contained in C:sccm2007sp1SCConfigMgr07_UPD_EN

Once it starts you can run the prerequisite checker to see what you need to fix before continuing...

Attached File  2post-1-1218226858.jpg   29.39K   33 downloads

you will be presented with a prerequisite check

Attached File  3post-1-1218227202.jpg   33.79K   33 downloads

I left everything as it was and clicked on OK

once done you'll get a list of errors that need to be resolved such as below, double click on any one to see what the recommended action is and then action each one

Attached File  4post-1-1218227590.jpg   54.27K   33 downloads

My first error told me that I needed to do as follows:

Quote

Configuration Manager out of band service point requires Windows Server 2003-based schannel hotfix. The schannel hotfix is available for download at: http://support.microsoft.com/kb/942841/en-us"http://support.microsoft.com/kb/942841/en-us.

as this was a hotfix i was pleasantly surprised to see that Microsoft now allow you to download the hotfix semi-directly, you have to enter your email address twice and input a number displayed on screen, you then get an email with the hotfix download details...

So I downloaded the first one and extracted it with the password supplied in the email.

Attached File  5post-1-1218228535.jpg   32.25K   35 downloads

While the hotfix installed I clicked OK on the prerequisite checker for SCCM 2007 sp1.

Once the hotfix was done installing, it wanted a reboot, so I rebooted. And then I ran the SCCM 2007 SP1 prerequisite checker again by starting at the beginning and running splash.hta...

This time however I was down to only 3 warnings :)

Attached File  6post-1-1218229679.jpg   51.67K   34 downloads


Next up I had to do the following:-

Quote

WinRM v1.1 is required to run the out of band console and must be installed before primary site or Configuration Manager console installations or upgrades. WinRM 1.1 is available for download at: http://support.microsoft.com/kb/KB936059.

That brought up a page with 3 download links (xp/windows server and so on).... confusing, inconsistent  ? yep.. but I got the following file


WindowsServer2003-KB936059-x86-ENU.exe


I must have been lucky because when I ran the SCCM sp1 prerequisite checker again, I was only shown 2 warnings (below)

Attached File  7post-1-1218230529.jpg   48.51K   33 downloads

Next up was my MMC update

Quote

This software update addresses several MMC errors that may occur when running the Configuration Manager console. This update should be applied if any of the following occur: Configuration Manager console stops responding when the host computer is low on available memory, context menu errors on console home pages, or inconsistent display after drag-and-drop operations do not succeed. More information about this update is available at: http://go.microsoft.com/fwlink/?LinkId=98349.

Once installed, I ran the SCCM 2007 SP1 pre requisite checker again, it told me i still needed this fix, so I decided to reboot (the hotfix didn't request it), the reboot didn't help it still listed it as a warning...

so I viewed the ConfigMgrPrereq.log file (stored in the root of C:) and it had a line that read

Failed to connect to registry for KB940848 with 203 that lead me to http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3607027&SiteID=17

Using regmon from Sysinternals I found the missing key and made a reg file of it, if you want it make sure you've applied the correct hotfix first then:-

FQDN Warning.

Attached File  8post-1-1218396112.jpg   51.97K   31 downloads

Quote

It is recommended to specify a Fully Qualified Domain Name(FQDN) for site systems in mixed mode Configuration Manager sites. It is required to specify an FQDN for site systems in native mode sites to allow clients to authenticate with site systems.

As my SCCM 2007 site is mixed mode I chose to resolve this warning by doing as follows:-

To fix the FQDN error try the following:


1.      Start SCCM Console

2.      Click Site Database

3.      Click Site Management

4.      Click on Site

5.      Click Site Settings

6.      Go to Site Systems

7.      Click on SCCM Server (where State Migration Point is located)

8.      Right click on “Configmgr Site System”

Attached File  9post-1-1218396245.jpg   82.56K   30 downloads

9.      Click on Properties

10.  In the "Specify a fully qualified domain name (FQDN) for this site system on the intranet” change the Intranet FQDN to something like my example here

it was WINDOWS-DOBMTWV

I changed it to windows-noob.sccm2007.local and clicked apply,

Attached File  10post-1-1218397526.jpg   44.92K   30 downloads

after waiting a few minutes for SCCM 2007 to udpate itself I ran the pre-req checker again and finally, success !

Attached File  11post-1-1218397644.jpg   44.31K   29 downloads




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top