Jump to content


0

Configure SCCM 2007 SP1 in Windows Server 2008 - Step 2


No replies to this topic

#1 t-zwck

t-zwck

    .::GhostInTheShell::.

  • Super Moderators
  • 759 posts
  • 9804 thanks

Posted 16 July 2009 - 02:56 PM

Step 1. We need to configure the Distribution Point (DP) and the Management Point (MP).

Open up the SCCM Configuration Manager Console, and highlight the SCCM server listed under site systems, in the right pane we'll see the role's we've already installed.

Attached File  1post-1-1219829688.jpg   89.36K   50 downloads

double click on ConfigMgr distribution point and place a checkmark in Allow clients to transfer content from this distribution point using BITS,...

Attached File  2post-1-1219829597.jpg   52.56K   54 downloads

Once done, click ok and Double click on Configmgr Management Point to bring up its' properties, put a checkmark in Allow devices to use this management point and click Apply.

Attached File  3post-1-1219829477.jpg   35.5K   52 downloads

At this point I checked my SCCM status (click System Status in the left pane, expand it, and choose Site Status, then your SCCM site code, then Component Status), this revealed there were problems with my Management Point which were preventing it from starting.

Attached File  4post-1-1219830544.jpg   173.03K   52 downloads

right-click on the Critical error, and choose Show Messages, All.

Attached File  5post-1-1219830715.jpg   23.48K   49 downloads

hidden inside one of the two re-occuring errors was this (you have to scroll in the error window to read it)

Quote

SMS Site Component Manager faild to install component SMS_MP_CONTROL_MANAGER on server WIN-2SDX7MZCDA7.

The WebDAV server extension is either not installed or not configured properly.
Solution: Make sure WebDAV is installed and enabled. Make sure there is an authoring rule that allow "All users" read access to "All content". Make sure the WebDAV settings "Allow anonymous property queries" and "Allow property queries with infinite depth" are set to "true" and "Allow Custom Properties" is set to false.

Attached File  6post-1-1219830859.jpg   90.71K   47 downloads

well, i know that Webdav is installed, but perhaps a slight configuration change is needed, so let's start up Server Manager and click on roles then select Web Server IIS and then Internet Information Services (IIS) Manager, then select your website listed under Sites (probably called Default Web Site unless you changed it). In the right side select WebDav Authoring Rules

Attached File  7post-1-1219831369.jpg   135.15K   47 downloads

Double click on WebDav authoring rules and you should see the rule you originally setup, click on Webdav Settings in the right pane.

Attached File  8post-1-1219831638.jpg   66.06K   45 downloads

so according to the error message above we need to verify the following:-

Solution:
Make sure WebDAV is installed and enabled. [it is]
Make sure there is an authoring rule that allow "All users" read access to "All content". [this rule is not setup yet]
Make sure the WebDAV settings "Allow anonymous property queries" and "Allow property queries with infinite depth" are set to "true" [they are currently set to false] and "Allow Custom Properties" is set to false.[it's set to true]


Ok, let's fix these WebDav problems starting with adding a new authoring rule. In WebDav settings, click on WebDav Authoring rules in the right pane

Attached File  9post-1-1219832316.jpg   65.05K   48 downloads

Next click on Add authoring rule under actions and make the changes as per below screenshot, click ok when done and you'll see your new authoring rule listed in Webdav.

Attached File  10post-1-1219832546.jpg   48.87K   48 downloads

Attached File  11post-1-1219832621.jpg   18.35K   49 downloads

Click on WebDav Settings now

make the changes above ("Allow anonymous property queries" and "Allow property queries with infinite depth" are set to "true", and "Allow Custom Properties" is set to false.)

Click Apply in the actions pane.

Attached File  12post-1-1219832799.jpg   30.44K   50 downloads

lastly you should change the WebDav Behaviour for Allow hidden files to be listed from False to True if this is going to be a Distribution Point using BITS (it is).

Attached File  13post-1-1237553659.jpg   39.46K   51 downloads

Ok back in SCCM Configuration Manager console, under site status, right click on your SITE and choose Reset Counts, then All. Pressing F5 (refresh) on your keyboard should refresh the system status.

Attached File  14post-1-1219833061.jpg   24.15K   49 downloads

A quick look back in System Status for our Management Point, now we can see that it has installed and started properly

Attached File  15post-1-1219834263.jpg   105.76K   45 downloads

(to speed up the automatic installation of this, you can use ConfigMgr's Service manager and select the SMS_Site_Component_manager server and restart the service.)

Attached File  16post-1-1219834295.jpg   55.26K   43 downloads




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Organization

Community

Downloads

Test Providers

Site Info


Go to top