Jump to content
Sign in to follow this  
Guest cmthiru

Juniper Secure SSL IVE 5.5 on VMWare

Recommended Posts

Guest cmthiru

Dear All,

 

Any one having Juniper Secure SSL IVE 5.5 on VMWare. If any one having Please upload it. I am having the same. But, i don't know how to get the console access. But i can access the web Access. I don't have the Username and Password for Admin login.

 

Regards,

CMThiru.

Share this post


Link to post
Share on other sites

add a serial port in vmware as a named pipe

example is

.pipeive1

 

download and install "Named Pipe TCP Proxy" program by A.Shvechkov

add a new pipe

.pipeive1, pick a port, like 2000

 

then use putty to telnet to 127.0.0.1 port 2000

then you can reset admin password from ive console.

 

the same thing works for Juniper Olive...

Share this post


Link to post
Share on other sites
Guest cmthiru

Hai,

 

Thank you. Its working for me now. If you know How to make VMWare image from .bin or .pkg file. Please guide me the steps.

Share this post


Link to post
Share on other sites

i haven't tried that, I know that SA runs linux, so it maybe possible to get bin file installed. The real issue is how to get licenses to work...

Share this post


Link to post
Share on other sites
Guest cmthiru

Hi Jintao,

I have the .pkg image for SA. Which Linux is the Base for this. I don't know how to make the SA run on VMWare. If you know the procedure Kindly tell me that to me. It may help me out.

Share this post


Link to post
Share on other sites

This is what I found, SA runs "security-hardened Linux operating system, derived from the Red Hat implementation. On top of this is a custom SSL web server written to act both as a proxy and a portal to applications protected by the appliance."

(excerpt from

Hidden Content

    Give reaction to this post to see the hidden content.
)

 

i have a backup drive for SA6000 somewhere in my office. Let me play around with it and see if i can figure out the file structure... there are some speculations that the drive has encrypted fs...

 

also, there are a bunch of duplicate partitions for Factory OS and Rollback, logs and /tmp.

 

I have a SA1000 box with a busted hard drive, I was planning to see if i can recover that clunker. Swapping drives with SA6000 does not work as 6k uses 80GB WD SATA and 1k uses 40GB IDE, and ghosting didnt work...

Share this post


Link to post
Share on other sites

A few words of wisdom....

 

The Neoteris/Juniper IVE box has a licensing mechanism, that matches a hardware serial number to a specially generated (by juniper) seven word license key that unlocks one or more features. This is true with SA2000, 4500, 6000 and on. Same thing with older SA1000, 3000 and 5000 boxes. Considering that SA1000 has a plain vanilla 1u server SuperMicro motherboard with a P4 2.6 GHz CPU inside, the hardware id is likely stored somewhere in the BIOS.

 

The license key is a combination of noun words.

for example (this is a fake one btw): truck harvest paper desk shovel rail junk

each combo is specific to the s/n and is responsible for unlocking the following features:

-Network Connect

-WSAM

-Network Connect and WSAM

-Advanced Editing Features

-LAB License (usually a low (10-20) user count with all features unlocked)

-Licensed users (in any combination 10-10000)

-Advanced Malware Protection

 

As far as i can remember with introduction of version 6, NC and WSAM are no longer licensed as a separate product, they are part of core user license.

 

In addition, without proper licenses, IVE will kick into 1 user version, only allowing administrator access. However, there is a workaround: if you restore a functional backup of ive configuration files from a licensed box, it will function for 90 days. But it will let you know that licenses are invalid... This is the ICE feature (in case of emergency)...

Share this post


Link to post
Share on other sites

Here's the breakdown of the currently supported and latest releases of IVE

 

5.5R7 - very stable, many people prefer to run it.

6.0R11 - very stable, supports Vista

6.1R7 - pretty good, fixed a lot of bugs

6.2R6 - pretty good, fixed a lot of bugs

6.3R5 - pretty good, fixed a lot of bugs, 64 bit support, NSM support

6.4R2 - good for playing around, but still has tons of bugs

6.5R1 - just came out, tons of bugs, not to be used in production

 

Here's the latest release 5.5 of IVE (5.5R7)

http://rapidshare.com/files/278706346/IVE_5.5R7.0.zip.html

Share this post


Link to post
Share on other sites
Guest cmthiru

Hi Jintao,

 

I have IVE 5.5R7 on VMWare. I tried to upgrade IVE 6.0R10, but it doesn't work for me. Which Release will support for this (upgrade from 5.5R7 to Upper versions). Kindly help me out.

Share this post


Link to post
Share on other sites

as far as i know, there are no problems jumping from one version to the other..

the upgrade procedure does not replace any files, it actually creates a separate filesystem, formats it, installs software and then copies configuration and logs... thats why you have rollback and factory restore partitions..

 

also can you share the vmware image...so that some of us can play with it...

dump it to rapidshare or something...

Share this post


Link to post
Share on other sites

add a serial port in vmware as a named pipe

example is

.pipeive1

 

download and install "Named Pipe TCP Proxy" program by A.Shvechkov

add a new pipe

.pipeive1' date=' pick a port, like 2000

 

then use putty to telnet to 127.0.0.1 port 2000

then you can reset admin password from ive console.

 

the same thing works for Juniper Olive...

[/quote']

 

very good and value information. thank you for the advise

Hidden Content

    Give reaction to this post to see the hidden content.

Share this post


Link to post
Share on other sites

Hi jintao

 

I am new to this Forum, i got much info from this form, i have IVE 5.5R7 will you pleae write down the steps how to install it in vmware, Thanks in Advance and waiting your reply.

 

FACH

Share this post


Link to post
Share on other sites

Here's the breakdown of the currently supported and latest releases of IVE

 

5.5R7 - very stable' date=' many people prefer to run it.

6.0R11 - very stable, supports Vista

6.1R7 - pretty good, fixed a lot of bugs

6.2R6 - pretty good, fixed a lot of bugs

6.3R5 - pretty good, fixed a lot of bugs, 64 bit support, NSM support

6.4R2 - good for playing around, but still has tons of bugs

6.5R1 - just came out, tons of bugs, not to be used in production

 

Here's the latest release 5.5 of IVE (5.5R7)

http://rapidshare.com/files/278706346/IVE_5.5R7.0.zip.html

[/quote']

 

hi there, is this software only for virtual implementations or will it work on a sa700 as well? i have one here but it gives a lot of trouble with vista and itunes (bonjour) service so i wanted to upgrade to newer software.

Share this post


Link to post
Share on other sites

Hi Redsupra

 

Thanks for your reply, I have downloaded the IVE 5.5R7 but i need to know how to install .bin file in VMWARE(Linux) please wirte down the stpes.

 

THANKS

FACH

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...