Jump to content
a1234id

Working on L2IOU - june20-2012-golden_spike

Recommended Posts

So far on initial test

 

- L2 etherchannel working

- L3 etherchannel not working

- Arp flooding bug is gone

- ISL still not working only dot1q trunking will

- HSRP Virtual IP working and Pingable

- Only Switch mode trunk option "no mode dynamic"

- Port Security works

 

 

 

I cannot confirm that HSRP VIP is pingable:

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

Hidden Content

    Give reaction to this post to see the hidden content.

Edited by trunto

Share this post


Link to post
Share on other sites

btw " ARP flooding bug is gone " ..have you guys confirmed this with redundant links ?

i was in the middle of configuring K7 initials and could not ping

looked on SW4 and there were collision messages

tried the ARP limit solution

did not work

went ahead with my 100% working HolyGrail solution and bam

back in business

just thought .would check with others and see what they are experiencing

 

 

as far as K7

also if someone can please clarify BB configs for me .. need to know what routes / protocols are bb sending into the network

i think bb2 and bb3 send bgp routes

Share this post


Link to post
Share on other sites

try removing arp-limiting on the control-plane

 

mine works..

 

SW1#show run

Building configuration...

 

Current configuration : 2249 bytes

!

! Last configuration change at 10:22:32 EST Sat Oct 13 2012

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SW1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

clock timezone EST -5

!

ip cef

no ip domain-lookup

!

no ipv6 cef

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan 10, 20

!

!

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Ethernet0/0

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 10.10.10.2 255.255.255.0

standby 1 ip 10.10.10.1

standby 1 preempt

!

interface Vlan20

ip address 20.20.20.2 255.255.255.0

standby 1 ip 20.20.20.1

standby 1 preempt

!

!

ip forward-protocol nd

no ip http server

!

 

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

transport input all

!

end

 

 

SW2#show run

Building configuration...

 

Current configuration : 2397 bytes

!

! Last configuration change at 10:22:30 EST Sat Oct 13 2012

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SW2

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

clock timezone EST -5

!

ip cef

no ip domain-lookup

!

no ipv6 cef

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

vlan 10, 20

!

!

!

!

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Ethernet0/0

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

duplex auto

channel-group 1 mode desirable

!

interface Ethernet1/0

duplex auto

!

interface Ethernet1/1

duplex auto

!

interface Ethernet1/2

duplex auto

!

interface Ethernet1/3

duplex auto

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 10.10.10.3 255.255.255.0

standby 1 ip 10.10.10.1

standby 1 preempt

!

interface Vlan20

ip address 20.20.20.3 255.255.255.0

standby 1 ip 20.20.20.1

standby 1 preempt

!

!

ip forward-protocol nd

no ip http server

!

!

!

!

!

 

line con 0

logging synchronous

line aux 0

line vty 0 4

login

transport input all

!

end

 

SW2# show cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

D - Remote, C - CVTA, M - Two-port Mac Relay

 

Device ID Local Intrfce Holdtme Capability Platform Port ID

SW1 Eth 0/1 178 R S Linux Uni Eth 0/1

SW1 Eth 0/0 138 R S Linux Uni Eth 0/0

SW1 Eth 0/3 135 R S Linux Uni Eth 0/3

SW1 Eth 0/2 125 R S Linux Uni Eth 0/2

SW2#

 

SW2#show inter status

 

Port Name Status Vlan Duplex Speed Type

Et0/0 connected trunk auto auto unknown

Et0/1 connected trunk auto auto unknown

Et0/2 connected trunk auto auto unknown

Et0/3 connected trunk auto auto unknown

Et1/0 connected 1 auto auto unknown

Et1/1 connected 1 auto auto unknown

Et1/2 connected 1 auto auto unknown

Et1/3 connected 1 auto auto unknown

Po1 connected trunk auto auto

SW2#show int tru

SW2#show int trunk

 

Port Mode Encapsulation Status Native vlan

Po1 on 802.1q trunking 1

 

Port Vlans allowed on trunk

Po1 1-4094

 

Port Vlans allowed and active in management domain

Po1 1,10,20

 

Port Vlans in spanning tree forwarding state and not pruned

Po1 1,10,20

SW2#

 

SW2#show stand br

P indicates configured to preempt.

|

Interface Grp Pri P State Active Standby Virtual IP

Vl10 1 100 P Active local 10.10.10.2 10.10.10.1

Vl20 1 100 P Standby 20.20.20.2 local 20.20.20.1

SW2#ping 10.10.10.255

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.255, timeout is 2 seconds:

 

Reply to request 0 from 10.10.10.2, 4 ms

Reply to request 1 from 10.10.10.2, 1 ms

Reply to request 2 from 10.10.10.2, 1 ms

Reply to request 3 from 10.10.10.2, 1 ms

Reply to request 4 from 10.10.10.2, 1 ms

SW2#ping 10.10.10.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

SW2#ping 10.10.10.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

SW2#ping 10.10.10.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

SW2#ping 20.20.20.255

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.255, timeout is 2 seconds:

 

Reply to request 0 from 20.20.20.2, 4 ms

Reply to request 1 from 20.20.20.2, 1 ms

Reply to request 2 from 20.20.20.2, 4 ms

Reply to request 3 from 20.20.20.2, 1 ms

Reply to request 4 from 20.20.20.2, 4 ms

SW2#ping 20.20.20.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

SW2#ping 20.20.20.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

SW2#ping 20.20.20.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms

SW2#

Edited by a1234id

Share this post


Link to post
Share on other sites

@a1234id: But you are pinging the VIP from one of the members of the HSRP group. Of what use is that? Try pinging it from outside of the group...

Share this post


Link to post
Share on other sites

@a1234id: But you are pinging the VIP from one of the members of the HSRP group. Of what use is that? Try pinging it from outside of the group...

 

okay here is a proof..

 

i have connected a router on and assign to a vlan 20

 

SW2#show cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

D - Remote, C - CVTA, M - Two-port Mac Relay

 

Device ID Local Intrfce Holdtme Capability Platform Port ID

SW1 Eth 0/0 152 R S Linux Uni Eth 0/0

SW1 Eth 0/1 178 R S Linux Uni Eth 0/1

SW1 Eth 0/2 176 R S Linux Uni Eth 0/2

SW1 Eth 0/3 172 R S Linux Uni Eth 0/3

R3 Eth 1/0 175 R Linux Uni Eth 0/0

 

SW2#show cdp ne e1/0 de

-------------------------

Device ID: R3

Entry address(es):

IP address: 20.20.20.254

Platform: Linux Unix, Capabilities: Router

Interface: Ethernet1/0, Port ID (outgoing port): Ethernet0/0

Holdtime : 138 sec

 

Version :

Cisco IOS Software, Linux Software (I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.2(2.3)T, ENGINEERING WEEKLY BUILD, synced to V151_4_M1_13

Copyright © 1986-2011 by Cisco Systems, Inc.

Compiled Thu 13-Oct-11 01:08 by hlo

 

advertisement version: 2

Duplex: half

Management address(es):

 

SW2#

 

SW2#show run int e1/0

Building configuration...

 

Current configuration : 93 bytes

!

interface Ethernet1/0

switchport access vlan 20

switchport mode access

duplex auto

end

 

SW2#show stand br

P indicates configured to preempt.

|

Interface Grp Pri P State Active Standby Virtual IP

Vl10 1 100 P Active local 10.10.10.2 10.10.10.1

Vl20 1 100 P Standby 20.20.20.2 local 20.20.20.1

 

 

R3>ping 20.20.20.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

R3>ping 20.20.20.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R3>ping 20.20.20.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.3, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

R3>scn

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

D - Remote, C - CVTA, M - Two-port Mac Relay

 

Device ID Local Intrfce Holdtme Capability Platform Port ID

SW2 Eth 0/0 129 R S Linux Uni Eth 1/0

R3>en

R3#show cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

D - Remote, C - CVTA, M - Two-port Mac Relay

 

Device ID Local Intrfce Holdtme Capability Platform Port ID

SW2 Eth 0/0 123 R S Linux Uni Eth 1/0

R3#show cdp ne de

-------------------------

Device ID: SW2

Entry address(es):

IP address: 20.20.20.3

Platform: Linux Unix, Capabilities: Router Switch

Interface: Ethernet0/0, Port ID (outgoing port): Ethernet1/0

Holdtime : 178 sec

 

Version :

Cisco IOS Software, Linux Software (I86BI_LINUX_L2-UPK9-M), Experimental Version 15.0(20120621:060510) [dstivers-june20-2012-golden_spike 101]

Copyright © 1986-2012 by Cisco Systems, Inc.

Compiled Wed 20-Jun-12 23:58 by dstivers

 

advertisement version: 2

VTP Management Domain: ''

Native VLAN: 20

 

R3#ping 20.20.20.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/6 ms

R3#ping 20.20.20.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R3#ping 20.20.20.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.20.20.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/6 ms

 

R3#show ip int br

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 20.20.20.254 YES NVRAM up up

Ethernet0/1 unassigned YES NVRAM administratively down down

Ethernet0/2 unassigned YES NVRAM administratively down down

Ethernet0/3 unassigned YES NVRAM administratively down down

R3#

 

if you get into some problem try to reload the switches.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...