Jump to content
Popperlau

Issue on router-on-a-stick topology + DHCP assignement + inter-vlan routing

Recommended Posts

Hi folks,

 

I am running a router-on-a stick topology with 2 different vlans, each one for a subnet for separate data and voice traffic.

The router has 2 Fa0/0 subinterfaces, one for each vlan I want to make inter-communicate.

Also, this router has 2 dhcp pools configured, again one for data and the other one for the ip phones.

The uplink interface on the switch connecting hosts and ip phones is configured as a trunk.

From the router, I can see the two subnets:

 

MADrouter#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

192.168.0.0/25 is subnetted, 2 subnets

C 192.168.0.0 is directly connected, FastEthernet0/0.1

C 192.168.0.128 is directly connected, FastEthernet0/0.10

MADrouter#

 

But the I cannot ping any host beyond the switch, and vice-versa.

Hosts are able to communicate between themselves and L2. Problem seems to be on the router.

Also, DHCP seems not to be working properly: I set up two excluded ip ranges and the hosts are taking ip´s from those ranges.

 

Router config:

!

ip dhcp excluded-address 192.168.0.1 192.168.0.10

ip dhcp excluded-address 192.168.0.129 192.168.0.139

!

ip dhcp pool VLAN_Datos

network 192.168.0.0 255.255.255.128

default-router 192.168.0.1

ip dhcp pool VLAN_VoIP

network 192.168.0.128 255.255.255.128

default-router 192.168.0.129

option 150 ip 192.168.0.9

!

!

interface FastEthernet0/0

description **Link a MADswitch**

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.0.1 255.255.255.128

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.0.129 255.255.255.128

!

 

 

What am I doing wrong?

 

PD: Find attached the .pkt lab I´m building with this topology.

Share this post


Link to post
Share on other sites

he's obviously got ip routing on because of his routing table.

 

has the dhcp service started? sometimes you need to do it

 

try

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

I dont believe you need the helper address because your router is in the same subnet as the DHCP clients

Share this post


Link to post
Share on other sites

hello Popperlau,

 

did you create a truck port on the switch to route information between the switch and the router, also did you assigned the vlan's to the interfaces;

 

Examples

interface FastEthernet0/1

switchport access vlan 1

switchport mode access

switchport voice vlan 10

spanning-tree portfast

!

interface FastEthernet0/24

description CONNECTION TO ROUTER1

switchport trunk encapsulation dot1q

switchport mode trunk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...