Jump to content
Sign in to follow this  
opotonil

Cisco 1801 bridge

Recommended Posts

Hi all.

 

I have the next config in the Cisco 1801:

 

interface FastEthernet0.1

encapsulation dot1Q 1 native

bridge-group 1

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 192.168.0.2 255.255.255.0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface Vlan1

no ip address

bridge-group 1

!

bridge 1 protocol ieee

 

The native vlan 1 has remote DHCP service but when I put a PC in FastEthernet[1-8] it can't get IP address.

 

Thanks.

Share this post


Link to post
Share on other sites

this isn't bridging, you've to have a bridge interface for this function, what are your goals? isn't clear for me, the 1801 have 8 layer 2 switchport and layer 3 (f0/0). If your dhcp is behind the router, you've to configure dhcp relay service. describe your needs better :)

Share this post


Link to post
Share on other sites

The goal at this time is manage a BGP session in Cisco 1801 (PoE) in trunk vlan 2 (DMZ) and in the native vlan 1 (secure) put a Cisco Phone 7911 that gets IP from remote DCHP (pass through).

 

Thanks.

Edited by opotonil

Share this post


Link to post
Share on other sites

still not enough information for configure it through cli (bgp as, routes, dhcp server's ip address, and so on) ... I think you should use CCP GUI, this approach is much easier for first time users, and the native vlan never secure, it should be always shutdown and never use in production environment.

Share this post


Link to post
Share on other sites

Ok, if FastEthernet0 is layer 3 and FastEthernet[1-8] is layer 2... it is done.

 

 

Current configuration : 1562 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname gateway

!

boot-start-marker

boot system flash c180x-advipservicesk9-mz.124-15.T17.bin

boot-end-marker

!

!

no aaa new-model

!

!

dot11 syslog

!

!

ip cef

!

!

!

multilink bundle-name authenticated

!

!

vtp mode transparent

!

!

archive

log config

hidekeys

!

!

vlan 2

!

!

!

!

interface Tunnel0

ip address 172.23.1.161 255.255.255.252

tunnel source 192.168.2.254

tunnel destination xx.xxx.xxx.xxx

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet1

switchport access vlan 2

switchport mode trunk

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 192.168.2.254 255.255.255.0

!

router bgp xxxxx

no synchronization

bgp router-id 172.23.1.161

bgp log-neighbor-changes

network xx.x.xx.xxx mask 255.255.255.252

neighbor 172.23.1.162 remote-as xxxxx

no auto-summary

!

ip forward-protocol nd

ip route xx.x.xx.xxx 255.255.255.255 Vlan2 192.168.2.2

ip route xx.xxx.xxx.xxx 255.255.255.255 Vlan2 192.168.2.1

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

!

end

 

 

The BGP is untested but all other work is ok:

- ping to network 192.168.1.0/24 fail (ok)

- ping to network 192.168.2.0/24 ok (ok)

- the Cisco IP Phone 7911 gets DHCP IP on network 192.168.1.0/24 (ok)

 

-----

ping 192.168.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

-----

ping 192.168.2.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

----

 

I know it is a untypical config and I can need revise my network schema to not use native vlan as you recommend.

 

Thanks.

Edited by opotonil

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...