Jump to content
Sign in to follow this  
ysarun

CCNA EIGRP Simulation

Recommended Posts

EIGRP Simulation

 

After adding Interior router, no routing updates are being exchanged between Perimeter and the new location. All other inter connectivity and Internet access for the existing locations of the company are working properly.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

The Task is to identify the fault(s) and correct the router configurations to provide full connectivity between the routers.

 

Access to the router CLI can be gained by clicking on the appropriate host.

 

All passwords on all routers are cisco.

 

IP Address are listed in the chart below

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

Hidden Content

    Give reaction to this post to see the hidden content.

Steps


  • Remove invalid Autonomous System Number and add the correct Autonomous System Number Interior router.
     
    The Autonomous System Number is found in the topology:
     

    Hidden Content

      Give reaction to this post to see the hidden content.


  • Add the network address of Fa0/0 interface of Perimeter router in EIGRP configuration. Because EIGRP neighbor relationship is not possible without the configuring connected interfaces.

 

Answer

Commands

First we should check the configuration of the Interior Router.

Click the console PC “F” and enter the following commands.

 

Interior> enable

Password: cisco

Interior# show running-config

Building configuration...

Current configuration : 770 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Interior

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

interface FastEthernet0/0

ip address 192.168.77.34 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.60.65 255.255.255.240

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 192.168.60.81 255.255.255.240

duplex auto

speed auto

!

router eigrp 22

network 192.168.77.0

network 192.168.60.0

no auto-summary

!

ip classless

!

line con 0

line vty 0 4

login

!

end

Interior#

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router Interior router with the following commands:

 

Interior# conf t

Interior(config)# no router eigrp 22

Interior(config)# router eigrp 222

Interior(config-router)# network 192.168.60.0

Interior(config-router)# network 192.168.77.0

Interior(config-router)# no auto-summary

Interior(config-router)# end

Interior# copy running-config startup-config

 

Second we should check the configuration of the Perimeter Router.

Click the console PC “G” and enter the following commands.

 

Perimeter> enable

Password: cisco

Perimeter# show running-config

Building configuration...

Current configuration : 1029 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Perimeter

!

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0

!

interface FastEthernet0/0

ip address 192.168.77.33 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.36.13 255.255.255.252

clock rate 64000

!

interface Serial0/1

ip address 192.168.60.25 255.255.255.252

clock rate 64000

!

interface Serial1/0

ip address 198.0.18.6 255.255.255.252

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

router eigrp 222

network 192.168.36.0

network 192.168.60.0

network 192.168.85.0

network 198.0.18.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 198.0.18.5

!

line con 0

line vty 0 4

login

!

end

Perimeter#

Notice that it is missing a definition to the network Interior. Therefore we have to add it so that it can recognize Interior router

 

Perimeter# conf t

Perimeter(config)# router eigrp 222

Perimeter(config-router)# network 192.168.77.0

Perimeter(config-router)# end

Perimeter# copy running-config startup-config

 

Now the whole network will work well. You should check again with ping command from router Interior to other routers!

 

In Short:

 

Interior RouterInterior>enable

Password: cisco Interior# conf t

Interior(config)# no router eigrp 22

Interior(config)# router eigrp 222

Interior(config-router)# network 192.168.60.0

Interior(config-router)# network 192.168.77.0

Interior(config-router)# no auto-summary

Interior(config-router)# end

Interior# copy running-config startup-config

 

 

Perimeter RouterPerimeter>enable

Password: cisco Perimeter# conf t

Perimeter(config)# router eigrp 222

Perimeter(config-router)# network 192.168.77.0

Perimeter(config-router)# end

Perimeter# copy running-config startup-config

 

Download Lab file (requires packet tracer)

Hidden Content

    Give reaction to this post to see the hidden content.

 

 

Some Modification in Question

After adding Interior router, no routing updates are being exchanged between Perimeter and the new location. All other inter connectivity for the existing locations of the company are working properly. But Internet connection for existing location including Remote1 and Remote2 networks are not working. Faults Identified:

1. Incorrect Autonomous System Number configured in Interior router.

2. Perimeter router does not advertise route to the new router Interior.

3. Internet Connection is not working all stations.

We need to correct the above two configuration mistakes to have full connectivity

 

Steps:

1. Interior Router: Change the Autonomous System Number of Interior

2. Perimiter Router: Add the network address of interface of Permiter that link between Perimeter and Interior.

3. Perimiter Router: Add default route and default-network.

 

Check the IP Address of S1/0 interface of Perimeter Router using show running-config command. (The interfaced used to connect to the ISP)!

interface Serial1/0

ip address 198.0.18.6 255.255.255.252

!

 

For Internet sharing we have create a default route, and add default-network configuration. The IP address is 198.0.18.6/30. Then the next hop IP will be 198.0.18.5.

 

Interior Router

Interior>enable

Password: cisco Interior# conf t

Interior(config)# no router eigrp 22

Interior(config)# router eigrp 222

Interior(config-router)# network 192.168.60.0

Interior(config-router)# network 192.168.77.0

Interior(config-router)# no auto-summary

Interior(config-router)# end

Interior# copy running-config startup-config

 

 

Perimeter RouterPerimeter>enable

Password: cisco Perimeter# conf t

Perimeter(config)# router eigrp 222

Perimeter(config-router)# network 192.168.77.0

Perimeter(config-router)# exit

 

Perimeter(config)# ip route 0.0.0.0 0.0.0.0 198.0.18.5

Perimeter(config)# ip default-network 198.0.18.0

Perimeter(config)# exit

Perimeter# copy running-config startup-config

 

 

Important:

 

If you refer the topology and IP chart, the Perimeter router uses Fa0/0 to connect Interior router, S0/0 used to connect Remote1, and S0/1 used to connect Remote2.

 

Refer to the command show running-config, the command #PASSIVE-INTERFACE <Interface Name> will deny EIGRP updates to specified interface. In that case we need to use #no passive-interface <Interface Name> to allow the routing updates to be passed to that interface. For example when used the #show run command and we see the output like below.!

router eigrp 22

network 192.168.77.0

network 192.168.60.0 passive-interface FastEthernet 0/0

passive-interface Serial 1/0 no auto-summary

!

 

Then the command would be

 

Perimeter(config)#router eigrp 222

Perimeter(config-router)#no passive-interface Fa0/0 Perimeter(config-router)#end

Also Perimeter router connect to the ISP router using Serial 1/0. If you seen passive-interface s1/0, then do not remove it using #no passive-interface s1/0 command.

 

 

 

 

Download Lab file (requires packet tracer)

Hidden Content

    Give reaction to this post to see the hidden content.

Hidden Content

    Give reaction to this post to see the hidden content.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...