Jump to content
Sign in to follow this  
hariskhan

configuring l2vpn on single router

Recommended Posts

Hi guys,

I have experience in configuring MPLS l2vpn on different routers but does any body know how to configure them on a single router when customer sites are residing on different interfaces and when customer sites are residing on same interface.You know in service provider networks they use BRAS to connect multiple customers to single router and then route their traffic.what if customer's both sites which he wants to connect are on single interface.If some body have experience with that please share your ideas and configuration

thanks.

  • Like 2

Share this post


Link to post
Share on other sites

Not Much Experience here but why don't you just use an SVI - Switched virtual Interface on the router so that the interfaces are within the router and not on the interface.

Share this post


Link to post
Share on other sites

I am identifying customer connections on single interface using vi(virtual interfaces or virtual circuits).Each customer site is with with separate PPPoe connection having separate virtual interface but same physical interface.I am intending to xconnect them,in xconnect I use loop back to identify the peer router.Since source peer and destination peer is the same route how do i make xconnect.

Thanks for the reply I was not expecting an answer :).

Share this post


Link to post
Share on other sites

Just starting out with my L2VPN studies but I would say you have two options here:

  • Both customer connections are terminated in the same VLAN - In this case it's just plain simple default L2 operations and you don't need an xconnect.
  • Both customer connections are terminated in different VLANs - This might make more sense. In this case I would create an xconnect with your own Loopback IP address as the "peer." Use the pseudowire ID to identify the xonnect.

Example configuration of the top of my head (for the second case):

 

interface Loopback0

ip address 11.22.33.44 255.255.255.255

!

interface Vlan10

no ip address

xconnect 11.22.33.44 1020 encapsulation mpls

interface Vlan20

no ip address

xconnect 11.22.33.44 1020 encapsulation mpls

!

interface FastEthernet0/1.10

description CUSTOMER 1

encapsulation dot1q 10

interface FastEthernet0/1.20

description CUSTOMER 2

encapsulation dot1q 20

!

Edited by Tommetje

Share this post


Link to post
Share on other sites

The concept you need here is local switching there are two solutions I would attempt, by the way this is crap design mainly because of the non-redundancy aspect.

 

 

Vlan to Vlan Local Switching

 

interface FastEthernet0/0.1

encapsulation dot1q 1

!

interface FastEthernet0/0.2

encapsulation dot1q 2

!

connect VLAN2VLAN FastEthernet0/0.1 FastEthernet0/0.2

 

 

 

Or L2TPv3 Local Switching

 

pseudowire-class L2TP-1

encapsulation l2tpv3

ip local interface Loopback1

!

pseudowire-class L2TP-11

encapsulation l2tpv3

ip local interface Loopback11

!

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

interface Loopback11

ip address 11.11.11.11 255.255.255.255

!

interface FastEthernet0/0

xconnect 11.11.11.11 111 pw-class L2TP-1

!

interface FastEthernet0/1

xconnect 1.1.1.1 111 pw-class L2TP-11

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...