Jump to content
tyrion

Multicast VPN tips

Recommended Posts

Hi,

 

I was wondering if you guys could share your experience on the lab regarding multicast issues you have found and tips you think would be relevant about it.

 

I did my first attempt and did not pass (Lab 3.2). One of the problemas was related to MVPN. I was sure that all I need was configure correctly, but router 12 was not able to ping router 14 and vice versa. R13 and R11 were working just fine.

 

Any help would be appreciated.

 

Thank you.

Share this post


Link to post
Share on other sites

That is why I would appreciated comments and tips about it. In my labs I did not face issues configuring it. Maybe in the real lab anyone have noticed a different behavior.

Share this post


Link to post
Share on other sites

You need to keep an eye on your RPF, specially if the generated multicast ( ping ) traffic is coming to your receipient through its RPF interface. On IOU I have seen also situations, where I lost pim neighborship over the MDT in a core sporadically, resulting also in the same problem as you described.

Share this post


Link to post
Share on other sites

it happened to me many time on rack.... at the end whenever i remove mdt default command and re enter... it works... what could be reason???

Share this post


Link to post
Share on other sites

@itsmubi

 

you might be hitting a bug in the IOS, the removal and reconfiguration you use is one of the most usable workarounds. Sometimes there is a need to deactivate and reactivate even ip multicast-routing for that particular vrf.

Share this post


Link to post
Share on other sites

Having the same problem. I have changed RP from R11 to R13, and vice versa. I can get reply from R11 to R13 and from R11 to R14, but any other combination does not work. My PIM neighbor VRF also does not show the MDT entries at all. I have tried removing and adding MDT default again but no luck. All tunnels are up. I do not know what else to do, may try with rack rentals. Right now I am using GNS3 and IOS.

Edited by ludek

Share this post


Link to post
Share on other sites

Having limited access to XR, I had a hard time remembering how to configure MDT in the lab exam, I ended up resorting to checking the documentation. Good thing I have lots of time so this is one of the last things I tried to fix.

 

Key things i remember is to check:

 

in XR,

- mdt source Lo0 command should be there

- mdt default 239.255.x.x command should be there.

- the interface should be configured under the multicast-routing

- the router pim should have the vrf ABC and the rp-address commands

 

in IOS,

- the ip pim vrf ABC rp-address command is required

- PIM-SM should be enabled in the interface between the PE-CE and the CE-CE

- when redistributing from the CE, you should redistribute the connected routes, otherwise, you should always use source Lo0 when doing ping tests.

 

HTH

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...