Jump to content
Stanikzai

Lab 3.2 CSC

Recommended Posts

Hi Guys,

 

i came with a wired situation where i used to lab 3.2 in IOU and online racks, but not yet started my online racks and still practicing in IOU, the question is that all the configuration are seamless and i don't see any issue, but after configuring CSC between the XYZ sites, XYZ Site 3 is getting routes from R15 and R16 and then it removes back, either it comes and disappeared again??

 

Now there is two points which needs to be cleared, where Sanajana's WB shows that there should be BGP v6 session between R15 and R10 where R10 is connected to R16, so this should be R16 and R10 only and when you are configuring the ospf between client, do we need to put the VRF-LITE capability option under R15 or R16? since R16 is doing redistribution but i tried both of them, the route is bouncing like coming and going back, rest all the MPLS LDP are working perfectly and other sites are normal, i only face this issue in whole lab, anyone else got the same issue??

 

I not yet applied on real gear, will try that soon, but do i need to take care of any special way to resolve this?

 

Beside on section 2 if you block the default route toward R20 (Latest requirement of Lab 3.2) you can easily put the command of ignore-attached-bit under ISIS process but you will lose connection toward R1,R8,R9 and R10 but from ISIS domain, all routers can reach R20 Loopback expect R8, and when you remove the ignore-attached-bit everything is working normally any one else face this issue?

 

 

Thanks, looking forward.

Share this post


Link to post
Share on other sites

I'll take a guess of what I think is happening with the routes being installed and removed. When you configure BGP VPNv4 sessions for CSC keep in mind that there was no BGP before there.

So, I think when you did that, you probably forgot to do "no bgp default ipv4-unicast". I believe I have seen a similar behavior when doing this. Try adding the command all all sessions to see if fixes your issue.

 

Here is my understanding . The Down-bit is set whenever a route is redistributed from MPBGP to OSPF (R10). Now when R15 receives those routes from R16 he will drop them because of the Bit. So in order for you do disable this check, you use cabability VRF-lite on R15 to get the routes installed.

Edited by CoreRouterX

Share this post


Link to post
Share on other sites

well re-tried and seems it worked now and not yet face that issue, but i didn't tried to use - no bgp default ipv4-unicast - command, i do put them now and seems it is working without any issue, but not sure if that was IOU issue or else. but need to check on real gear. anyways thanks for your response.

Share this post


Link to post
Share on other sites

Ihave another issue in csc. Site3 xyz can't reach site 2 when removed next-hop-unchanged on vpnv4 session between 15 and 13 . it works. Any one can explain?

Share this post


Link to post
Share on other sites

There is not BGP between R15 and R13? it should be R16 and R13 and if the routes are not passing, check the MPLS LDP between R1 and R2 and R7-R8. Mostly MPLS LDP is causing some issue.

Share this post


Link to post
Share on other sites

Actually ASBRs will use BGP + Label. IOS automatically adds this when a BGP VPNv4 session is created. In XR you can just allocate the label under the VRF address family so you will only have MPLS ldp within you IGP environment.

Share this post


Link to post
Share on other sites

no conf. needed on XR-1,2 my ASBR routers R7,8

i've site 1 can reach 2 and 3 but site 3 cant see 2

i can see it when i removed next-hop-unchanged

Share this post


Link to post
Share on other sites

last update

issue solved when i shut down interface between XR-1 and R8 ,

till know i didnt find out the reason

please help

Share this post


Link to post
Share on other sites

Ihave another issue in csc. Site3 xyz can't reach site 2 when removed next-hop-unchanged on vpnv4 session between 15 and 13 . it works. Any one can explain?

 

By default eBGP changes the next-hop, so using next-hop-unchanged just insures that your Inter-AS traffic does not follow the RRs as as next-hop by preserving the original next-hop (just gives you better routing but they both should work).

 

Now let's think about your issue here. If you are removing next-hop-unchaged and it works then that tells me that the BGP next-hop for you CSC routes is not reachable. Is working because is using the RRs interface as next hop which are reachable.

 

Check the following:

 

1) If you "sh ip route" on all 6 CSC PE do you have all the routes?

2) Are they all pingable?

3) Are you pinging using source loopback0, or if you are doing straight up pings are you redistributing connected were needed?

4) check "sh mpls forwarding". Are you allocating labels?

5) Verify that you have LDP configure on all IGP links on all 3 sites and that you have BGP+Label for all non IGP links.

Edited by CoreRouterX

Share this post


Link to post
Share on other sites

thank you corerouterx

here my answer

 

By default eBGP changes the next-hop, so using next-hop-unchanged just insures that your Inter-AS traffic does not follow the RRs as as next-hop by preserving the original next-hop (just gives you better routing but they both should work).

 

Now let's think about your issue here. If you are removing next-hop-unchaged and it works then that tells me that the BGP next-hop for you CSC routes is not reachable. Is working because is using the RRs interface as next hop which are reachable.

 

Check the following:

 

1) If you "sh ip route" on all 6 CSC PE do you have all the routes? yes

2) Are they all pingable? yes

3) Are you pinging using source loopback0, or if you are doing straight up pings are you redistributing connected were needed? yes i can ping all 172.0.x except 172.9.0.2 .

4) check "sh mpls forwarding". Are you allocating labels? yes

5) Verify that you have LDP configure on all IGP links on all 3 sites and that you have BGP+Label for all non IGP links. confirmed

 

thank u, i notice this issue happened when R7,8 are Ebgp-vpnv4 in inter AS but when i changed it to R1,2 it solved

Share this post


Link to post
Share on other sites

Ok.

1) show me the following config: "sh run vrf abc" and "show run router bgp <AS> vrf abc" on both R1 & R2

 

2) check if you have "mpls bgp forwarding" on R7 & R8 ebgp serial interfaces.

 

3) show me for R7 and R8 the configuration for eBGP peering and "sh bgp vpnv4 unicast all summary"

Edited by CoreRouterX

Share this post


Link to post
Share on other sites

XR1

 

vrf ABC

address-family ipv4 unicast

import route-target

9:9

1009:9

!

export route-target

1009:9

!

!

address-family ipv6 unicast

import route-target

9:9

1009:9

!

export route-target

1009:9

!

!

!

 

RP/0/0/CPU0:XR1#sh run router bgp 1009 vrf ABC

Fri Aug 29 18:11:07.916 UTC

router bgp 1009

vrf ABC

rd 1009:9

address-family ipv4 unicast

network 172.9.0.1/32

!

address-family ipv6 unicast

network 2002:172:9::1/128

!

!

!

 

XR2

vrf ABC

address-family ipv4 unicast

import route-target

9:9

1009:9

!

export route-target

9:9

!

!

address-family ipv6 unicast

import route-target

9:9

1009:9

!

export route-target

9:9

!

!

!

 

RP/0/0/CPU0:XR2#sh run router bgp 9 vrf ABC

Fri Aug 29 18:13:06.308 UTC

router bgp 9

vrf ABC

rd 9:9

address-family ipv4 unicast

network 172.9.0.2/32

!

address-family ipv6 unicast

network 2002:172:9::2/128

!

!

!

 

R7

 

router bgp 9

bgp router-id 9.9.0.7

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 9.9.0.2 remote-as 9

neighbor 9.9.0.2 update-source Loopback0

neighbor 9.9.0.3 remote-as 9

neighbor 9.9.0.3 update-source Loopback0

neighbor 9.9.0.4 remote-as 9

neighbor 9.9.0.4 update-source Loopback0

neighbor 9.9.0.5 remote-as 9

neighbor 9.9.0.5 update-source Loopback0

neighbor 9.9.0.6 remote-as 9

neighbor 9.9.0.6 update-source Loopback0

neighbor 9.9.78.8 remote-as 1009

neighbor 2002:9:9::2 remote-as 9

neighbor 2002:9:9::2 update-source Loopback0

!

address-family ipv4

no synchronization

network 9.9.0.7 mask 255.255.255.255

neighbor 9.9.0.2 activate

neighbor 9.9.0.2 route-reflector-client

neighbor 9.9.0.2 next-hop-self

neighbor 9.9.0.3 activate

neighbor 9.9.0.3 route-reflector-client

neighbor 9.9.0.3 next-hop-self

neighbor 9.9.0.4 activate

neighbor 9.9.0.4 route-reflector-client

neighbor 9.9.0.4 next-hop-self

neighbor 9.9.0.5 activate

neighbor 9.9.0.5 route-reflector-client

neighbor 9.9.0.5 next-hop-self

neighbor 9.9.0.6 activate

neighbor 9.9.0.6 route-reflector-client

neighbor 9.9.0.6 next-hop-self

neighbor 9.9.78.8 activate

neighbor 9.9.78.8 route-map lp in

no auto-summary

exit-address-family

!

address-family vpnv4

neighbor 9.9.0.2 activate

neighbor 9.9.0.2 send-community extended

neighbor 9.9.0.2 route-reflector-client

neighbor 9.9.0.2 next-hop-self

neighbor 9.9.0.3 activate

neighbor 9.9.0.3 send-community extended

neighbor 9.9.0.3 route-reflector-client

neighbor 9.9.0.3 next-hop-self

neighbor 9.9.0.4 activate

neighbor 9.9.0.4 send-community extended

neighbor 9.9.0.4 route-reflector-client

neighbor 9.9.0.4 next-hop-self

neighbor 9.9.0.5 activate

neighbor 9.9.0.5 send-community extended

neighbor 9.9.0.5 route-reflector-client

neighbor 9.9.0.5 next-hop-self

neighbor 9.9.0.6 activate

neighbor 9.9.0.6 send-community extended

neighbor 9.9.0.6 route-reflector-client

neighbor 9.9.0.6 next-hop-self

neighbor 9.9.78.8 activate

neighbor 9.9.78.8 send-community both

exit-address-family

!

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

9.9.0.2 4 9 95 123 49 0 0 01:16:06 1

9.9.0.3 4 9 109 153 49 0 0 01:39:15 2

9.9.0.4 4 9 107 153 49 0 0 01:39:17 4

9.9.0.5 4 9 117 155 49 0 0 01:39:08 5

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

9.9.0.6 4 9 117 155 49 0 0 01:39:09 5

9.9.78.8 4 1009 78 80 49 0 0 01:02:40 8

 

 

R8

 

router bgp 1009

bgp router-id 9.9.0.8

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 9.9.0.1 remote-as 1009

neighbor 9.9.0.1 update-source Loopback0

neighbor 9.9.0.9 remote-as 1009

neighbor 9.9.0.9 update-source Loopback0

neighbor 9.9.0.10 remote-as 1009

neighbor 9.9.0.10 update-source Loopback0

neighbor 9.9.78.7 remote-as 9

neighbor 2002:9:9::1 remote-as 1009

neighbor 2002:9:9::1 update-source Loopback0

!

address-family ipv4

no synchronization

network 9.9.0.8 mask 255.255.255.255

neighbor 9.9.0.1 activate

neighbor 9.9.0.1 route-reflector-client

neighbor 9.9.0.1 next-hop-self

neighbor 9.9.0.9 activate

neighbor 9.9.0.9 route-reflector-client

neighbor 9.9.0.9 next-hop-self

neighbor 9.9.0.10 activate

neighbor 9.9.0.10 route-reflector-client

neighbor 9.9.0.10 next-hop-self

neighbor 9.9.78.7 activate

neighbor 9.9.78.7 route-map lp in

no auto-summary

exit-address-family

!

address-family vpnv4

neighbor 9.9.0.1 activate

neighbor 9.9.0.1 send-community extended

neighbor 9.9.0.1 route-reflector-client

neighbor 9.9.0.1 next-hop-self

neighbor 9.9.0.9 activate

neighbor 9.9.0.9 send-community extended

neighbor 9.9.0.9 route-reflector-client

neighbor 9.9.0.9 next-hop-self

neighbor 9.9.0.10 activate

neighbor 9.9.0.10 send-community extended

neighbor 9.9.0.10 route-reflector-client

neighbor 9.9.0.10 next-hop-self

neighbor 9.9.78.7 activate

neighbor 9.9.78.7 send-community both

exit-address-family

!

 

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

9.9.0.1 4 1009 96 120 60 0 0 01:18:25 1

9.9.0.9 4 1009 134 145 60 0 0 01:41:46 4

9.9.0.10 4 1009 126 145 60 0 0 01:41:48 4

9.9.78.7 4 9 82 80 60 0 0 01:04:22 16

 

__________________________

 

mpls bgp forwarding on the interfaces.

 

 

also I see starnge output on R9

Routing Table: ABC

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route, + - replicated route

 

Gateway of last resort is not set

 

172.9.0.0/16 is variably subnetted, 25 subnets, 2 masks

B 172.9.0.1/32 [200/0] via 9.9.0.1, 01:13:08

B 172.9.0.2/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.3/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.4/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.5/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.6/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.10/32 [200/0] via 9.9.0.10, 01:27:02

B 172.9.0.11/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.12/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.13/32 [200/0] via 9.9.0.8, 01:08:00

B 172.9.0.14/32 [200/0] via 9.9.0.8, 01:08:01

B 172.9.0.16/32 [200/409600] via 9.9.0.10, 01:27:03

B 172.9.34.0/24 [200/0] via 9.9.0.8, 01:08:01

B 172.9.106.0/24 [200/0] via 9.9.0.10, 01:27:03

B 172.9.112.0/24 [200/0] via 9.9.0.8, 01:08:01

B 172.9.113.0/24 [200/0] via 9.9.0.8, 01:08:01

B 172.9.125.0/24 [200/0] via 9.9.0.8, 01:08:01

B 172.9.134.0/24 [200/0] via 9.9.0.8, 01:08:01

B 172.9.146.0/24 [200/0] via 9.9.0.8, 01:08:01

B 172.9.146.14/32 [200/0] via 9.9.0.8, 01:08:01

 

 

R9#sh mpls forwarding-table vrf ABC | inc 172.9.0

90000 16008 172.9.0.1/32[V] 590 Et0/0 9.9.19.1

90001 80025 172.9.0.13/32[V] 21229

90006 Pop Label 172.9.0.15/32[V] 129644 Et1/0 172.9.159.15

90008 100008 172.9.0.16/32[V] 0 Et0/1 9.9.109.10

90009 100014 172.9.0.10/32[V] 1770 Et0/1 9.9.109.10

90013 Pop Label 172.9.0.9/32[V] 14822 aggregate/ABC

90021 80026 172.9.0.14/32[V] 610

90026 80016 172.9.0.2/32[V] 5490

90027 80017 172.9.0.3/32[V] 610

90028 80018 172.9.0.4/32[V] 610

90029 80020 172.9.0.5/32[V] 610

90030 80019 172.9.0.6/32[V] 610

90031 80021 172.9.0.11/32[V] 610

90032 80022 172.9.0.12/32[V] 32554

 

there no outgoing interface for vrf prefixes !!

 

i think this is the problem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...