Jump to content
funabashi

vMX beta

Recommended Posts

I think you could see some config example (mine too) with vlan configuring in this thread. I suppose you have problem with switching toward vMX, but not with xVM itself. As far as i try lot of features on vMX are working. It is not Olive, mate.

 

Dude, i am desperate, i have tried your config too, and the output packets don't have the 802.1Q header. Can you check this config in your gns3 and with wireshark and confirm that works for you? is your cofnig posted on other post related vlans

 

[email protected]> show configuration

## Last commit: 2015-04-24 11:34:22 UTC by root

version 14.1R1.10;

system {

host-name vMX-1;

root-authentication {

encrypted-password "$1$iiqdh9ru$CBQygri2MkpfgtgdGo8GO1"; ## SECRET-DATA

}

login {

user lab {

uid 2000;

class super-user;

authentication {

encrypted-password "$1$oW1NeMUu$N7IVMfy8GfJ02jzQzJ39h/"; ## SECRET-DATA

}

}

}

services {

telnet {

connection-limit 5;

}

}

syslog {

user * {

any emergency;

}

file messages {

any notice;

authorization info;

}

file interactive-commands {

interactive-commands any;

}

}

}

logical-systems {

r1 {

interfaces {

ge-0/0/0 {

unit 0 {

family inet {

address 10.1.1.1/24;

}

}

}

}

}

r2 {

interfaces {

ge-0/0/1 {

unit 0 {

family inet {

address 10.1.1.2/24;

}

}

}

}

}

}

interfaces {

ge-0/0/3 {

mac 00:0c:29:c1:ff:06;

unit 0 {

family bridge {

interface-mode trunk;

vlan-id-list [ 139 200 ];

}

}

}

em0 {

unit 0 {

family inet {

address 192.168.56.10/24;

}

}

}

irb {

unit 139 {

family inet {

address 172.25.1.69/24;

}

}

unit 200 {

family inet {

address 5.5.5.5/29;

}

}

}

}

bridge-domains {

VLAN139 {

vlan-id 139;

routing-interface irb.139;

}

VLAN200 {

vlan-id 200;

routing-interface irb.200;

}

}

Share this post


Link to post
Share on other sites

I am also new to Juniper. I did not know that vMx or Mx has switching support.

Share this post


Link to post
Share on other sites

Dude, i am desperate, i have tried your config too, and the output packets don't have the 802.1Q header. Can you check this config in your gns3 and with wireshark and confirm that works for you? is your cofnig posted on other post related vlans

 

There is same question on 25th time. Check mac-address on your irb-interface. Do you see some differences? Can your virtual switch do mac-learning? I think, no.

Share this post


Link to post
Share on other sites

There is same question on 25th time. Check mac-address on your irb-interface. Do you see some differences? Can your virtual switch do mac-learning? I think, no.

 

on the irb? the .doc says that we have to copy the em2 mac to the ge/0/03 and i did it. i have tried to copy the em2 mac to ge/0/03 and to irb unit 139 (not at the same time) and didnt worked the 802.1q header....

Edited by alvicas802

Share this post


Link to post
Share on other sites

on the irb? the .doc says that we have to copy the em2 mac to the ge/0/03 and i did it. i have tried to copy the em2 mac to ge/0/03 and to irb unit 139 (not at the same time) and didnt worked the 802.1q header....

 

1) i tried to configure your bridge - it does not work, it is not right configuration.

2) mac address on irb is different of ge-interfaces.

Share this post


Link to post
Share on other sites

1) i tried to configure your bridge - it does not work, it is not right configuration.

2) mac address on irb is different of ge-interfaces.

 

thanks, i will check my config but i dont get the second point: you mean mac address of the irb must be the same of the ge interface ? in that case, i red again the doc and didnt see something about it

Share this post


Link to post
Share on other sites

Sergei :)

 

You know people prefer to keep asking questions and not to read stupid documentation as borring forum threads :)

Get used to it..

Share this post


Link to post
Share on other sites

Just FYI:

 

as i said here, my problem was that the output packets flowed withouth 802.1Q header. my config posted here WAS RIGHT and DID WORK. I did read a lot of times de .doc and the forum, the problem was not there, THE REAL PROBLEM was that my REALTEK NIC was configured to strip the vlan tags. I found a web with the windows register to change this behaviour

Share this post


Link to post
Share on other sites

Hello everyone.

 

1) what is the right way to configure lt interface to interconnect logical systems?

according to an official documentation, entire lt configuration is done inside LS, for example:

 

set logical-systems LS1 interfaces lt-0/1/0 unit 0 encapsulation ethernet

set logical-systems LS1 interfaces lt-0/1/0 unit 0 peer-unit 1

set logical-systems LS1 interfaces lt-0/1/0 unit 0 family inet address 10.0.8.13/30

 

Another method is to configure lt interface inside physical router and then assign lt to a logical system.

First method is not working for me (routes and address is not seen inside LS, empty output), second one works without an issue.

 

 

2) Did anyone try to configure vrrp entirely for logical systems, is it possible?

in my case when I'm assigning vip for a backup router, error is generated:

 

 

'vrrp-group 1'

Duplicate virtual-ip : 192.168.1.1 detected on interface: lt-0/0/10 unit: 25 vrrp-group: 1 for address: 192.168.1.3 on logical-system default routing-instance default

Share this post


Link to post
Share on other sites

Great news!

vMX is expected to be available after 1st July 2015.

There are promised 3 versions of vMX:

1. Trial full version for 90 days

2. Modeling/education version with limited throughput - free

3. Full version with licensing of bandwidth and featureset - paid

 

Presentation -

Hidden Content

    Give reaction to this post to see the hidden content.

  • Like 1

Share this post


Link to post
Share on other sites

I have found several versions of vMX here:

Hidden Content

    Give reaction to this post to see the hidden content.

 

Does anybody tried to install and use RE and MPC instances?

Edited by slimy_cat
  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...