Jump to content
root0

Cisco CSR1000v Collections

Recommended Posts

i am stuck on the message below, any suggestion guys?

 

Package type:0x7531, flags:0x0

[Linux-bzImage, setup=0x3c00, size=0x2142994]

[isord @ 0x7e330000, 0x1cbf444 bytes]

Share this post


Link to post
Share on other sites

sub-interface is not working in eve-ng with Version 16.6.2. Which is the best image for practicing CSR1000v with sub-interface.

Share this post


Link to post
Share on other sites

sub-interface is not working in eve-ng with Version 16.6.2. Which is the best image for practicing CSR1000v with sub-interface.

 

UD posted on the eve-ng forums that the newer CSR1k images that are prepared for KVM do not work with dot1q. He said that VIRL images will work. I haven't had the chance to test myself, having the same issue that you are though.

 

Hidden Content

    Give reaction to this post to see the hidden content.

  • Like 5

Share this post


Link to post
Share on other sites

UD posted on the eve-ng forums that the newer CSR1k images that are prepared for KVM do not work with dot1q. He said that VIRL images will work. I haven't had the chance to test myself, having the same issue that you are though.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

I am using 3.17 release and subinterface works fine

  • Like 3

Share this post


Link to post
Share on other sites

^ 3.17 is Fuji. (sorry I confused the version, 16.7 is Fuji).

Edited by nwt

Share this post


Link to post
Share on other sites

3.10S - 3.17S - it is old software EOL ( Equivalent IOS 15.x )

16.2.x - 16.3.x - Denali

16.4.x - 16.6.x - Everest

16.7.x - 16.8.x - Fuji

Edited by root0

Share this post


Link to post
Share on other sites

Issue is only with Everest and Denali. Sub-interface works fine with 3.17S. Can some share the VIRL Everest and Denali images.

Share this post


Link to post
Share on other sites

About Cisco CSR 1000v Collections, I have no more knowledge but i am sure if you want to more detail and completely solution then watch some tutorial related to this topic on website.

Thanks & Regards

Edited by shivkumar23
Rule Reminder.

Share this post


Link to post
Share on other sites

Does anybody have troubles with sub interfaces(dot1q) configured on newest Everest images in eve-ng?

 

My topology : R1-SW-R2

 

R1:

interface GigabitEthernet1

no ip address

negotiation auto

!

interface GigabitEthernet1.12

encapsulation dot1Q 12

ip address 10.0.0.1 255.255.255.0

!

 

SW:

 

interface Ethernet0/0

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Ethernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

 

R2:

 

!

interface GigabitEthernet1

no ip address

negotiation auto

!

interface GigabitEthernet1.12

encapsulation dot1Q 12

ip address 10.0.0.2 255.255.255.0

!

 

No ping reply at all from R1 to R2.

 

Tested csr1000v-universalk9.16.07.01 and csr1000v-universalk9.16.06.02

 

On older images everything is working

 

subinterface work.I test csr1000v-universalk9.16.07.01 in eve-ng. here is this test:

 

magnet:?xt=urn:btih:D60BD05F27EDD3E5A65B1E13C35CF73B7D615060&dn=csr1000v-universalk9.16.07.01.qcow2

 

Router#show ver

Cisco IOS XE Software, Version 03.16.00.S - Extended Support Release

Cisco IOS Software, CSR1000V Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.5(3)S, RELEASE SOFTWARE (fc6)

Technical Support:

Hidden Content

    Give reaction to this post to see the hidden content.

Copyright © 1986-2015 by Cisco Systems, Inc.

Compiled Sun 26-Jul-15 20:16 by mcpre

 

 

Cisco IOS-XE software, Copyright © 2005-2015 by cisco Systems, Inc.

All rights reserved. Certain components of Cisco IOS-XE software are

licensed under the GNU General Public License ("GPL") Version 2.0. The

software code licensed under GPL Version 2.0 is free software that comes

with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such

GPL code under the terms of GPL Version 2.0. For more details, see the

documentation or "License Notice" file accompanying the IOS-XE software,

or the applicable URL provided on the flyer accompanying the IOS-XE

software.

 

 

ROM: IOS-XE ROMMON

 

Router uptime is 19 minutes

Uptime for this control processor is 21 minutes

System returned to ROM by reload

System image file is "bootflash:packages.conf"

Last reload reason: <NULL>

 

 

 

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

 

A summary of U.S. laws governing Cisco cryptographic products may be found at:

Hidden Content

    Give reaction to this post to see the hidden content.

 

If you require further assistance please contact us by sending email to

[email protected]

 

License Level: ax

License Type: Default. No valid license found.

Next reload license Level: ax

 

cisco CSR1000V (VXE) processor (revision VXE) with 1095671K/6147K bytes of memory.

Processor board ID 9IAV6H57189

10 Gigabit Ethernet interfaces

32768K bytes of non-volatile configuration memory.

3022272K bytes of physical memory.

1482751K bytes of virtual hard disk at bootflash:.

 

Configuration register is 0x2102

 

Router#

Router#

Router#

 

 

Router#show run int gi2

Building configuration...

 

Current configuration : 67 bytes

!

interface GigabitEthernet2

no ip address

negotiation auto

end

 

Router#show run int gi2.10

Building configuration...

 

Current configuration : 100 bytes

!

interface GigabitEthernet2.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

end

 

Router#show run int gi2.20

Building configuration...

 

Current configuration : 100 bytes

!

interface GigabitEthernet2.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

end

 

Router#show run | sec ospf

router ospf 100

network 0.0.0.0 255.255.255.255 area 0

Router#show ip ospf nei

 

Neighbor ID Pri State Dead Time Address Interface

192.168.1.1 1 FULL/BDR 00:00:36 192.168.20.100 GigabitEthernet2.20

192.168.1.1 1 FULL/BDR 00:00:33 192.168.10.100 GigabitEthernet2.10

Router#

Router#show ip ro ospf

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

a - application route

+ - replicated route, % - next hop override, p - overrides from PfR

 

Gateway of last resort is not set

 

O 192.168.1.0/24

[110/11] via 192.168.20.100, 00:00:46, GigabitEthernet2.20

[110/11] via 192.168.10.100, 00:00:56, GigabitEthernet2.10

Router#

Router#

Router#show lldp nei

Capability codes:

® Router, (

Hidden Content

    Give reaction to this post to see the hidden content.
/uploads/emoticons/default_cool.png"> Bridge, (T) Telephone, © DOCSIS Cable Device

(W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other

 

Device ID Local Intf Hold-time Capability Port ID

localhost Gi2 120 B,R Ethernet1

 

Total entries displayed: 1

 

Router#

Router#

Router#

 

Router#

Router#

Router#ping 192.168.1.1 sou 192.168.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

Packet sent with a source address of 192.168.10.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 21/23/31 ms

Router#ping 192.168.1.1 sou 192.168.20.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

Packet sent with a source address of 192.168.20.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 19/22/28 ms

Router#

Router#

Router#

 

I use csr1000v and vEOS direct connect.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...