Jump to content
blatz

UNL Networking Issue

Recommended Posts

I am having an issue with UNL with networking between my IOU routers '(I86BI_LINUX-ADVENTERPRISEK9-M), Version 15.5(2)T' and ASAs '8.4(2)'. I can't get RIP or NTP to work and OSPF is unstable and pings are pausing and timing out. I am running UNL on ESXi Anyone else seen this?

 

I am also having the hardest time getting 8.02 ASA to talk to anything. The interfaces come up and I can see the mac address in the switch table, but no pings. I have VT-X enabled too. I just wonder if there is something I am missing...

 

Feb 8 23:39:36.388: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from LOADING to FULL, Loading Done

Feb 8 23:42:49.203: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from FULL to DOWN, Neighbor Down: Dead timer expired

Feb 8 23:44:45.897: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from LOADING to FULL, Loading Done

Feb 8 23:45:59.327: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from FULL to DOWN, Neighbor Down: Dead timer expired

Feb 8 23:46:58.226: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from LOADING to FULL, Loading Done

Feb 8 23:47:46.603: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from FULL to DOWN, Neighbor Down: Dead timer expired

Feb 8 23:48:45.553: %OSPF-5-ADJCHG: Process 1, Nbr 11.45.45.11 on Ethernet0/1.415 from LOADING to FULL, Loading Done

Share this post


Link to post
Share on other sites

Get ASA 8.02 Vmware image from here http://certcollection.org/forum/topic/217818-cisco-emulation-collection-in-this-site/

 

I used ASA-m.7z

 

Then convert the vmdk's to qcows

221 /opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 ~/ASA-m/asahd.vmdk hda.qcow2

222 /opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 ~/ASA-m/Other\ Linux\ 2.6.x\ kernel.vmdk hdb.qcow2

 

And place them in the unetlab addons. Remember only works with 256M of ram. Otherwise you get the issue about not finding the root partition.

 

/opt/unetlab/addons/qemu/asa-8.0m/

/opt/unetlab/addons/qemu/asa-8.0m/hda.qcow2

/opt/unetlab/addons/qemu/asa-8.0m/hdb.qcow2

 

 

This image is multi-context originally. If you want single context you need for the issue with saving the configuration first..

Hidden Content

    Give reaction to this post to see the hidden content.

 

You need to do the format disk0: part.

 

 

Anyone else seeing packet loss between their ASA's and IOU's? This is without having a switch between them. Just the bridge Net even!

Edited by blatz
  • Like 1

Share this post


Link to post
Share on other sites

So I rebuilt my UNL VM and 8.02 networking worked there, so I went back to my old UNL VM and it worked there. So I restarted the firewalls and then it stopped working... the only thing I can see if that if I don't use the ASA immediately after booting. Like if I watch it boot, then configure it... no networking on 8.02. But If I start the ASA's then wait about 5 minutes before configure it.. it seems to work. This is only with 8.02. No issues like this with 8.42.

 

Ohh yeah my post eariler about switching from multi context to single.... I can't seem to reproduce it... and because I copied the qcows after it was single, I have both ASA-8.0M and ASA-8.0S devices on UNL. But I will try it again later today and document what I do!

Share this post


Link to post
Share on other sites

Great share, thank you very much.

It's working now.

But how to access linux to do :

# cd /mnt/disk0

# /mnt/disk0/lina_monitor

 

I'm still getting error when I try to swtich from multi to single mode :

ASA4(config)# mode single

WARNING: This command will change the behavior of the device

WARNING: This command will initiate a Reboot

Proceed with change mode? [confirm]

ERROR: The requested mode was not saved because the flash update failed.

Share this post


Link to post
Share on other sites

Ok. I remembered how I did it. You need to know a little linux, but it goes pretty quick.

 

 

Hidden Content

    Give reaction to this post to see the hidden content.

  • Like 1

Share this post


Link to post
Share on other sites

Hi blatz,

 

Would you please help to run ASA 8.0.2 in signel mode. i am using ASA-m.7z. and able to run multimode. but not able to run after changing signle mode.

After changing mode from multi to signle its asking for restart and did same then its going to # mode. Puting # cd /mnt/disk0

# /mnt/disk0/lina_monitor

command and then its stuck with below output

 

 

# cd /mnt/disk0

# /mnt/disk0/lina_monitor

 

Processor memory 22999040, Reserved memory: 20971520 (DSOs: 0 + kernel: 20971520)

Failed to reserve hugepages.

Requested 0

Reserved 30

physical area, size 65536 kB

free list: used list

 

# cd /mnt/disk0

# /mnt/disk0/lina_monitor

 

Processor memory 22999040, Reserved memory: 20971520 (DSOs: 0 + kernel: 20971520)

Failed to reserve hugepages.

Requested 0

Reserved 30

physical area, size 65536 kB

free list: used list

 

Thanks

Share this post


Link to post
Share on other sites

Hello,

 

Many thanks for helping with single mode image! However, I have an issue with saving config in single and multi context modes. The following error appears:

ciscoasa# wr

Building configuration...

Cryptochecksum: 75a1ab8d 67a3d116 2bd87367 7942168c

 

%Error opening disk0:/.private/startup-config ()

Error executing command

[FAILED]

 

I noticed that in the boot log:

INFO: Unable to read firewall mode from flash

Writing default firewall mode (single) to flash

WARNING: Unable to write firewall mode to flash, this is normal if flash is

not formatted.

 

So I tried to format flash & disk0, unfortunately, it didn't help:

ciscoasa# format disk0:

WARNING: Saving activation key file failed. Proceed with operation? [confirm]

 

Format operation may take a while. Continue? [confirm]

 

Format operation will destroy all data in "disk0:". Continue? [confirm]

Initializing partition - done!

mkdosfs: /dev/hda1 contains a mounted file system.

 

System tables written to disk

mount: Mounting /dev/hda1 on /mnt/disk0 failed: Device or resource busy

 

Format of disk0 complete

WARNING: Restoring security context mode failed.

ciscoasa# dir disk0:

 

Directory of disk0:/

 

4 drwx 4096 23:02:40 Nov 07 2016 .private

10 drwx 4096 21:22:38 Feb 18 2008 boot

7 drwx 4096 20:57:10 Feb 18 2008 csco_config

68 -rwx 1623 13:48:36 Sep 17 2008 y

69 -rwx 6889764 05:49:58 Feb 15 2010 asdm-602.bin

70 -rwx 2154944 15:57:10 Feb 15 2010 anyconnect-win-2.2.0140-k9.pkg

 

255320064 bytes total (246038528 bytes free)

ciscoasa# wr

Building configuration...

Cryptochecksum: 75a1ab8d 67a3d116 2bd87367 7942168c

 

%Error opening disk0:/.private/startup-config ()

Error executing command

[FAILED]

 

Is there a way to solve the problem with saving running configuration?

Share this post


Link to post
Share on other sites

Ok. I remembered how I did it. You need to know a little linux, but it goes pretty quick.

 

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

I created the HDA and HDB following Blatz instructions, I want to share them in case anyone needs, I created one for single-mode and one for multiple-context:

 

Hidden Content

    Give reaction to this post to see the hidden content.

Hidden Content

    Give reaction to this post to see the hidden content.

Edited by lopwal
  • Like 1

Share this post


Link to post
Share on other sites

Gents,

Can you share image for asa802, please

 

It is in this torrent. Remember only works with 256M of ram. Otherwise you get the issue about not finding the root partition.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

Use hide tags.

Usage: [ hide ] link [ /hide ] (without spaces)

Edited by mavis
Hide tag added.
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...