Jump to content
sxswpirates

H2+ DMVPN Variant R17 in VRF.

Recommended Posts

This conifiguration should resolve connectivity for the variation having R17's E0/1 (To Corp) ,Lo0, and Tunnel in the VRF, but not E0/0 (To ISP).

 

 

interface Ethernet0/1

vrf forwarding CORP

ip address 10.2.0.38 255.255.255.252

ip nat inside

!

interface Ethernet0/0

ip address 192.0.2.2 255.255.255.0

ip nat outside

!

interface Loopback0

vrf forwarding CORP

ip address 10.255.1.17 255.255.255.255

ip nat inside

ip virtual-reassembly in

!

interface Tunnel0

vrf forwarding CORP

ip address 10.100.0.1 255.255.255.0

no ip redirects

ip nhrp map multicast dynamic

ip nhrp redirect

ip ospf network point-to-multipoint

ip ospf hello-interval 10

ip ospf 1 area 51 no-summary

tunnel source Ethernet0/0

tunnel mode gre multipoint

!

ip nat inside source list all interface Ethernet0/0 vrf CORP overload

!

ip route vrf CORP 0.0.0.0 0.0.0.0 192.0.2.1 global

 

The ip ospf 1 area 51 no-summary will cause problems if you the Spokes have their WAN and LAN interfaces in the same route table. It will send a default route that conflicts with the IPCP learned default. You can solve this by using a specific route to the NMBA interface 0/0 of R17 instead of learning a default from IPCP, or having the dialer in a separate route table from the Tunnel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...