Jump to content
rajeevansingh

Lets Discuss K5..

Recommended Posts

Hi ALL,

 

 

Any one has done the K5 end to end ? Does anyone has the full question for BGP ( MPLS VPN). they say use the existing BGP connection ? so does it mean that we have to take the existing EBGP connection between the PE to CE, now as its clear whos is PE ( R1 and R3 ) but not clear who is CE what should be do in this case. As far as I understand it seems to be between R1 and SW1 and R3 and SW4 ( ebgp) , in the solution they have done something weird. any input ?????

 

 

Thanks.

Share this post


Link to post
Share on other sites

Hi ALL,

 

 

Any one has done the K5 end to end ? Does anyone has the full question for BGP ( MPLS VPN). they say use the existing BGP connection ? so does it mean that we have to take the existing EBGP connection between the PE to CE, now as its clear whos is PE ( R1 and R3 ) but not clear who is CE what should be do in this case. As far as I understand it seems to be between R1 and SW1 and R3 and SW4 ( ebgp) , in the solution they have done something weird. any input ?????

 

 

Thanks.

 

I have tested the solution and its working fine for me-

Dont redistribute connected under MBGP.

 

Adding config:

 

R1:

 

ip vrf vpn1yy

rd 100:1

route-target export 100:1

route-target import 100:1

route-target import 300:1

 

interface Serial3/0 -------------> Connected to R4 (PPP)

ip vrf forwarding vpn1yy

ip address 5.5.14.1 255.255.255.252

ip pim sparse-mode

encapsulation ppp

exit

 

router eigrp 1

no auto-summary

!

address-family ipv4 vrf vpn1yy

redistribute bgp 254 metric 1000 100 255 1 1500

network 5.5.14.1 0.0.0.0

no auto-summary

autonomous-system 5

exit-address-family

!

router bgp 254

bgp router-id 5.5.1.1

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 5.5.3.3 remote-as 254

neighbor 5.5.3.3 update-source Loopback0

neighbor 5.5.128.2 remote-as 55

neighbor 5.5.128.2 ebgp-multihop 10

neighbor 150.1.5.254 remote-as 254

!

address-family ipv4

neighbor 5.5.3.3 activate

neighbor 5.5.128.2 activate

neighbor 150.1.5.254 activate

neighbor 150.1.5.254 maximum-prefix 10 100 warning-only

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 5.5.3.3 activate

neighbor 5.5.3.3 send-community extended

exit-address-family

!

address-family ipv4 vrf vpn1yy

redistribute eigrp 5

no synchronization

exit-address-family

 

SAME way config for R5, with changing IP's.

 

TEST:

R1:

 

# sh ip eigrp vrf vpn1yy interface

--output: 14.2 (IP of R4 interface connected to R1)

 

# sh ip bgp vpn4 vrf vpn1yy YY.YY.23.2 255.255.255.252

 

--output: you will see in the output how route-target are imported/exported b/w R1 and R3.

23.2 is the IP of R2 serial interface connected to R3.

 

You might need to keep K5 diagram in front of you, while looking on above config.

Good Luck...

Share this post


Link to post
Share on other sites

I have tested the solution and its working fine for me-

Dont redistribute connected under MBGP.

 

Adding config:

 

R1:

 

ip vrf vpn1yy

rd 100:1

route-target export 100:1

route-target import 100:1

route-target import 300:1

 

interface Serial3/0 -------------> Connected to R4 (PPP)

ip vrf forwarding vpn1yy

ip address 5.5.14.1 255.255.255.252

ip pim sparse-mode

encapsulation ppp

exit

 

router eigrp 1

no auto-summary

!

address-family ipv4 vrf vpn1yy

redistribute bgp 254 metric 1000 100 255 1 1500

network 5.5.14.1 0.0.0.0

no auto-summary

autonomous-system 5

exit-address-family

!

router bgp 254

bgp router-id 5.5.1.1

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 5.5.3.3 remote-as 254

neighbor 5.5.3.3 update-source Loopback0

neighbor 5.5.128.2 remote-as 55

neighbor 5.5.128.2 ebgp-multihop 10

neighbor 150.1.5.254 remote-as 254

!

address-family ipv4

neighbor 5.5.3.3 activate

neighbor 5.5.128.2 activate

neighbor 150.1.5.254 activate

neighbor 150.1.5.254 maximum-prefix 10 100 warning-only

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 5.5.3.3 activate

neighbor 5.5.3.3 send-community extended

exit-address-family

!

address-family ipv4 vrf vpn1yy

redistribute eigrp 5

no synchronization

exit-address-family

 

SAME way config for R5, with changing IP's.

 

TEST:

R1:

 

# sh ip eigrp vrf vpn1yy interface

--output: 14.2 (IP of R4 interface connected to R1)

 

# sh ip bgp vpn4 vrf vpn1yy YY.YY.23.2 255.255.255.252

 

--output: you will see in the output how route-target are imported/exported b/w R1 and R3.

23.2 is the IP of R2 serial interface connected to R3.

 

You might need to keep K5 diagram in front of you, while looking on above config.

Good Luck...

 

 

 

 

 

I did .. K5.

 

R1- R3 .. .MPLS Backbone.. PE routers ..

very interesting lab.

IPv6 .. need to create tunnel between R1=SW2 , R3=SW3 ..

Share this post


Link to post
Share on other sites

I did .. K5.

 

R1- R3 .. .MPLS Backbone.. PE routers ..

very interesting lab.

IPv6 .. need to create tunnel between R1=SW2 , R3=SW3 ..

 

Yeah, this lab is very interesting. It also left me some confusions, for example if R1 & R3 becomes PEs and their interfaces facing R4 & R2 respectively are moved into VRF, some issues will arise and they might exclude some subnets from global reachability, eg: the link between R1-SW1, R3-SW4, R1's LB0, R3's LB0, R1-R3,... :o

  • Like 1

Share this post


Link to post
Share on other sites

Yeah, this lab is very interesting. It also left me some confusions, for example if R1 & R3 becomes PEs and their interfaces facing R4 & R2 respectively are moved into VRF, some issues will arise and they might exclude some subnets from global reachability, eg: the link between R1-SW1, R3-SW4, R1's LB0, R3's LB0, R1-R3,...

Hidden Content

    Give reaction to this post to see the hidden content.

 

THEIR VRF NETWORK WILL REACHABLE FROM GLOBAL THERE LO 0 AND INTERNAL NETWROK SHOULD NOT BE REACHABLE FROM GLOBAL NETWORK.

I WAS FACED PROBLEM IN NTP R1 HAVE TO SYN WITH R2 OR SW3 BUT IN R2 DESTINATION OF R1 IN SOLUTION LO 0 ..

 

WE DIDN'T HAVE REACHABLITIY OF LO 0 FOR R1-R3.

 

ONLY YY.YY.14.1 -- YY.YY.23.1

 

 

SO CAREFUL WHILE CREATING TUNNELS, NTP & OTHER STUFF WITH LOOPBACK OF R1 AND R3.

 

 

COME UP WITH MORE ISSUES IN K5 ..

Share this post


Link to post
Share on other sites

sometimes i feel we all express in the same language as the dumps are....gagan and some others out here, your grammar is very much similar to the way these passccie or cciecerts gives the tasks grr and dreaded KillCCIES....not to mention you have a problem with your capslock key.

Edited by suraj0220
  • Like 1

Share this post


Link to post
Share on other sites

sometimes i feel we all express in the same language as the dumps are....gagan and some others out here, your grammar is very much similar to the way these passccie or cciecerts gives the tasks grr and dreaded KillCCIES....not to mention you have a problem with your capslock key.

 

yes i have problem with capslocks ..

 

pls show ur grammar .. how u gonna describe ur thoughts about new labs ..

 

here poeple talking about discussion about new lab ..if u have done new lab pls give your suggestion.

  • Like 1

Share this post


Link to post
Share on other sites

Check this link may be helpful in understanding K5 MPLS... but not sure

Hidden Content

    Give reaction to this post to see the hidden content.

 

I need to ask is there any one reported that people facing K5 Lab ?? In version 3.0 CCIECert Introduced a Fake Lab X just to earn money .... I just know one guy from killccie group reported K5 lab.... and whatever he shared they created lab.....any comments plz

Share this post


Link to post
Share on other sites

Did you use a sub-interface between R1 and R3 ( frame-relay)??? if yes where did you configure mpls ip: under the main interface or under the sub-interface??

Share this post


Link to post
Share on other sites

Hi guys.

 

The lab is sooo confusing.

 

In the section of MPLS is being used as CE R4 and R2 when there is nothing to indicate that it should be. As I see it could be used as CE both SW1, SW4, R2 and R4, but in fact the question says "use of existing BGP connections." The existing BGP connections are between R1 <-> SW1 and R3 <-> SW4 and of course R1 <-> R3. It is clear who are the PE which does not happen with the CE. Perhaps we are saying that the CE is SW1 and SW4 and that we use as a routing protocol BGP between them?

 

I think this is the correct interpretation instead of using R4 and R2 as CE since nothing refers to them.

 

What do you think?

 

Regards.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...