Jump to content
Sign in to follow this  
t-zwck

Adding network drivers to Zero Touch WindowsPE

Recommended Posts

I got this error when trying to do a ZTI install of Vista on a modern Intel ICH9 dekstop with the Intel gigabit nic (vpro Network:Intel 825xx Gigabit Platform LAN Network Device Driver).

 

SMS Operating System Deployment

 

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

Could not connect to the installation package on servernameSMSPKGD$RIS0000D. The network location cannot be reached. For information about network troubleshooting, see Windows help. (800704CF)

 

This message will automatically close in 30 minutes.

 

[OK][/code]

 

It turns out that when I created the OS package in SMS, I didn't bother specifying any special network drivers, and thus, Windows PE couldnt communicate over the network to this computer.

 

to resolve this I first added the NIC (network) drivers to my deployment point in Deployment Workbench by clicking on Distribution share in the left pane and then selecting Out-Of-Box Drivers. I right clicked here, and selected New, and then used the wizard to point to the local path of the Intel Gigabit XP drivers. Once done I right clicked on my Deployment point and chose Update.

 

I then went back into SMS, clicked on Image Packages, then selected my vista image (Windows Vista Enterprise), right clicked on it and chose properties. I then clicked on the Drivers tab and entered the servernamesharenamepath path to my newly added network drivers on the Distribution$ share.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

I then clicked ok and it copied the files over, once done it informed me that the SMS distribuition points required updating, so I did that.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

once done your Windows Vista ZTI package will have a new folder added to it called CustomWinPE

 

eg:-

 

 

D:SMSPKGD$RIS0000DCustomWinPE

 

obviously in this example, SMSPKGD$ is an SMS sharing directory and RIS0000D is the Package ID of the package within that share.

 

If you browse the CustomWinPE folder, you will see there are INF and System32 subfolders which contain the network drivers you just added.

 

Please note that the above works nicely if you are adding only ONE new network driver, if you are adding more than one then it's a good idea to copy the contents of the newly created CustomWinPE folder to somewhere else, and manually copy in the CAT/SYS/INF and EXE files as appropriate (easy to figure out), then once done, copy the contents of that back to the original SMS package share as in the screenshot.

 

Hidden Content

    Give reaction to this post to see the hidden content.

 

In addition, once you have made the changes you will need to either completely re-deploy an os (eg: XP) on the client computer, and then rerun the ZTI advertisement to the client, OR you can manually boot the system using a WindowsPE usb key/cd and copy over the contents of the files within CustomWinPE to the c:MININT folder (eg: all files in INF must be copied to C:MININTINF and so on), then once done, power down, and reboot and the ZTI process will continue correctly without the original error

 

more informations

 

Hidden Content

    Give reaction to this post to see the hidden content.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...